My Macbook Pro 15inch with the touchbar stopped recognizing my external USB-C adapter Sinstar 8 in 1 Aluminum Multi Port Adapter . I should clarify perhaps, the HDMI port still works fine, but the laptop doesn't recognize the Ethernet cable when it's plugged in and also not USB devices. I haven't tested the Micro SD card slot (will do)

The adapter was working fine until couple weeks ago when it stopped connecting to my LAN network, few days later I noticed it doesn't recognize any of my USB devices on any on the port, though the USB slots are charged when I connect a phone or similar.

From Google search I have already discovered the the reason could be in the System Management Controller, so that should be reset.

Here is what I do.

  1. Unplug the power cable
  2. Power Off the Mac
  3. Press Shift-Control-Option together
  4. Press the power button and hold all keys together for 10 seconds
  5. Power on the Mac

I've tried both pressing all the keys together and pressing Shift-Control-Option first and the the Power button. Doesn't seem to make a different.

The problem remains. I've also tried to clear the NVRAM but also doesn't seem to working as expected. I see no loss in setting or any change at all on the laptop.

I have few questions of the subject, as I am new in the Mac world and any help would be appreciated

How do I know that SMC is reset properly? How do I know that the NVRAM is cleared? Is there something specific about the new 2017 Macbooks when it comes to resetting the SMC? I am I doing something wrong? Why is it not working?

P.S. I don't my devices listed in diskutil list Disk utility or the System Information under USB. I've tried different USB drives, such that have been recognized by the same setup until the problem at hand and also new devices. Please advise.

  • The SMC and NVRAM have nothing (directly) to do with the functionality of the USB port. If you can charge, you're getting the correct 5V from the port. If none of the ports are detected, it could related to the USB controller (it failed). Try booting into Safe Mode and see if the problem goes away. If it does, it's something that's being loaded. – Allan Apr 10 '18 at 13:59
  • I've tested in Safe Mode. It doesn't change anything. My worry at the moment is that something went wrong with the adapter itself. Let's not forget the ethernet ports also doesn't connect – imaginois Apr 10 '18 at 17:44
  • 1
    Are we talking about your hub or the actual USB ports on your MacBook? I'm only interested in the ports on your MacBook, not the adapter. – Allan Apr 10 '18 at 18:03
  • Unfortunately I don't have a USB-C type of device to test the ports directly. I've ordered a flash drive and I'll try to find somebody at the office tomorrow that have a USB-C type device so I can test it. What about the ethernet port? – imaginois Apr 10 '18 at 21:31
  • 1
    The Ethernet port is part of the hub and at present we have no idea if your USB port on the Mac is working or if the hub is working. I would bet the hub has failed. Can you try a different one? – Allan Apr 10 '18 at 21:35

Browse other questions tagged .