0

I have an iMac 27" Late 2015 with High Sierra installed. When I bought it, it came with Sierra installed, and when High Sierra was released I made a clean install but formatted my Fusion Drive to APFS. I had some problems but finally I got the 10.13.3 working properly. Now when I try to update to the 10.13.4 it simply doesn't update. Nor via Apple Store, not via downloading the whole installer of the update. And when I try to reinstall the whole system via a thumb drive I receive the “an error occurred while preparing the installation. Try running this application again” message. I have already corrected the date but even though it doesn't install. Any suggestions?

1

FWIW I had huge problems running 10.13.2 thru 10.13.4. I'm on an Apple RAID that's HFS+ formatted. But apparently Apple suddenly dropped support for all RAID, even their own. Very annoying. Fusion is not a raid but it's kind of raid-like in many ways, I can see how that could cause the same problem I've been dealing with. The update runs through the whole process, everything seems to work, then it reboots and is still on the old OS.

But here's how I finally had to upgrade my system: I had to clone my boot drive (the striped RAID) to a USB drive. Boot off that USB drive, and run all system software updates. They worked fine off a single, normal drive. Then I cloned back to my RAID volume. And obnoxious solution for sure, but it worked in my case, it may work for you.

0

Google tells me Fusion Drives & APFS are not the best of friends. Apparently they were supported at beta but not since release.

Ref: MacWorld - macOS High Sierra: latest update, problems, fixes, features & others

If you have a Fusion Drive you might want to hold of updating to High Sierra, although it should work fine, it just won’t be able to take advantage of one of the new features in High Sierra, the new Apple File System (APFS). More on APFS below,

APFS is limited to Macs with Flash storage (or SSDs). Excluding Fusion Drives, which combine Flash with a Hard Drive, and older Hard Drive equipped models.

I'd reformat to HFS+ & try again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .