MacOS could not be installed in your computer The installer resource were not found Quit the installer to restart the computer and try again

Pressed restart then it hang and get this MacOS message again

  • Sounds like reinstalling might be needed: support.apple.com/en-us/HT204904#recovery
    – Joonas
    Apr 9, 2018 at 6:40
  • I'm seeing the same thing. I booted into Safe Boot by holding down shift. This started up fine.I then went to the app store and tried the update again: this caused it to download again which I though was promising. BUT in the end I ended up with the same error message.
    – Walton
    Apr 9, 2018 at 9:23

1 Answer 1


This worked for me (could probably be streamlined). The goal is to remove macOS' files related to failing install attempt.

  1. Booted into to 'Safe Mode' by holding down shift while restarting.
  2. Opened a Terminal (/Applications/Utilities/Terminal.app)
  3. Deleted /Volumes/Macintosh HD/macOS Install Data as described here. I needed to use sudo and rm -rf so be careful. (Could also be done from macOS Recovery: see below, but Volume names may differ).
  4. Rebooted and got only a question mark. Uh Oh.
  5. Booted into macOS Recovery by holding down Command-R during reboot and selected the start-up disk to boot from.
  6. Restarted and ALL OKAY!

Will try the update again when feeling braver.

UPDATE: After backing up I took the cautious approach and downloaded the full combo update from https://support.apple.com/en_GB/downloads, manually killed any app that might mess with shutdown and ran the update package. It all worked fine this time around.

  • 1
    Thanks @patrix - I ended up with a working solution, so updated the answer rather than deleting it (there was a link as you said).
    – Walton
    Apr 9, 2018 at 10:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .