5

I am using a 2009 13" MacBook Pro running El Capitan 10.11. On my desktop, I strangely have a PDF with the name "Macintosh HD" and the properties of my main system drive.

The Properties window of the PDF file

Does anybody know why this is happening, or how I can resolve it?

  • The creation date is 23 December '17. Has it been there since that date, or did it just appear on the desktop. – IconDaemon Apr 7 '18 at 18:20
  • @IconDaemon It's been on the desktop since then, if memory serves. – Connor Gurney Apr 7 '18 at 18:28
  • BURN IT WITH FIRE! – But seriously though, you should report the file to an antivirus firm and don't open it. Google "report virus file for analysis". There will be links to trendmicro, microsoft, symantec, etc. Any of those should be fine. – Vladimir Apr 7 '18 at 20:42
  • If you are curious what the contents are (and you know how to use the Terminal), you can try the following commands. Get actual file size: ls -lh ~/Desktop/Macintosh\ HD*. Print the last 1000 bytes of the file: tail -c -1000 "enter the full name from the above command here" ; echo "" (Change the 1000 as needed. Keep the ; echo "" part because it's needed in case the file does not end in a new line.) – Vladimir Apr 7 '18 at 21:03
  • Correction to my "burn it with fire" comment: Since it's a mac, the companies I mentioned above might not find anything wrong with the file, so you can google "report virus file for analysis sophos" instead. Sophos makes antivirus software for macs. But even if none of these find the file as malicious, you should still be careful. Use my tail command from above to view the contents safely. – Vladimir Apr 7 '18 at 21:12
2

In all likelihood this is a bug.

A "real" PDF, or a malicious file (which would probably better hidden or disguised), would not show for "Get Info" things like "Capacity" etc.

If under Finder > Preferences > General the checkbox is set to
"Show these items on the desktop: harddisks" it just is displaying the correct name for the internal drive: "Macintosh HD" but mixes up somehow the filetype/association.

That means the suspected explanation in the question is exactly backwards:
Somehow the root drive/volume "Macintosh HD" is reported as kind "PDF".

To confirm this scenario, open a Terminal, type file (note the trailing space!) and drag the offending icon onto the Terminal window.

You should now see the following output or something similar:

$ file / 
/: directory

If that is the case, the solution is quite simple:

Open again the Finder preferences in the general tab and uncheck the "show hard disks on desktop" option,

enter image description here

and restart the Finder with a method of your choice. That might include a logout, login cycle, or just type in Terminal:

$ killall Finder

Now, even if you you re-tick that checkbox, your hard disk should show up with the proper icon and filetype.

If these steps fail, deleting the Finder preferences, and then the caches might be the next steps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .