4

Safari 11.1 running under macOS Sierra 10.12.6., on a mid-2013 MacBook Air. The software is all up to date.

I'd like Safari to use DuckDuckGo as its default search engine. However, when I choose DDG in the dropdown at Safari > Preferences > Search, the dropdown immediately and spontaneously reverts to Google, without further input from me. All other Safari functionality works correctly. Interestingly, I have exactly the same software running on a mid-2010 MacBook Pro, and that Safari allows search engine selection.

I have only two extensions (wipr and Omnikey) installed; removing them did not affect this behavior. Quitting Safari and the OS had no effect. Restarting in Safe Mode had no effect. Trashing the com.apple.safari.plist (from ~/Library/Preferences/) had no effect. Replacing the .plist with the plist from the correctly-operating MBP had no effect.

Any ideas how to remedy this?

4

I found a solution in this Apple Discussion thread.

It turns out that there are two places to select the search engine. Setting the search engine from Safari's URL bar overrides whatever's set in Safari > Preferences > Search. My Safari had Google set from the URL bar, and whatever I set in Safari Preferences was immediately reverted to Google.

To reset the default search engine in Safari's URL bar, click on the magnifying glass icon, which appears at the left side of the URL bar when no page is displayed. A dropdown appears. Then select which engine you'd choose. Luckily, I was content with DDG, one of the only four choices presented.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .