4

Switching the input with CMD+Space language works in Remote Desktop only if you disable the shortcut in MacOS. If it's enabled, it's received and handled by MacOS, even if you are in Remote Desktop fullscreen at the moment. So, instead of switching the remote input language, it switches the local one.

Are there any workarounds?

I'm thinking of something like "disable that system shortcut in that particular app", but I can't find the functionality neither in the MacOS, nor in Karabiner.

A relevant issue on Remote Desktop UserEcho

1 Answer 1

1

If anyone is facing this issue these days:

  1. Go to Settings > Keyboard > Shortcuts > Input sources.

Here is two (actually same-working) shortcuts. If you set Cmd+Space shortcut into the first one, then macOS, as vopou said, 'instead of switching the remote input language, switches the local one.'

  1. Set something different (Cmd+0) shortcut on the first shortcut, and then set Cmd+Space as the shortcut on the second one. Turn on the second one, then turn off the first one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .