2

I have an mbp mid-2012 running the latest Sierra. I installed the latest update which attempted to restart the machine. The usual progress bar was showing and then it shut off. Curiously, it didn't restart. Now, when i press the power button, the sleep led flickers and then dies along with the machine. The screen never turns on.

Things I've tried

  • resetting SMC

Are these symptoms familiar to anyone?

2

The number of times the sleep light flashed was an indicator of the problem. Three flashes means the Mac can't find any RAM.

Practically, this means the RAM you have installed is bad, or has a bad connection. Step one is re-seat like you did. Meaning remove and reinstall the RAM. If you still have problems, swap it out with some other compatible RAM and see what happens.

  • I'm reasonably sure it was more than 3 flickers, since the frequency was so high, but since it's been to working, I cannot check. – oarfish Apr 8 '18 at 7:58
  • I just had this problem again with the new security update (so clearly no coincidence). Reseating the ram alone did not help, but i actually work had to disconnect the battery for a time, after which reseating the ram into the bottom seat worked. It appears the top seat was broken by the update, the computer loudly beeps when a ram module is in there. – oarfish Jun 27 '18 at 8:27
1

In my case, it was sufficient to remove and reinstall the two RAM modules and disconnect and reconnect the battery. Probably it was just a coincidence that the update and the power-on problem appeared at the same time.

1

Just did the latest update with my iMac and it looked stuck on the white screen with progress bar after already restarting twice.

I went and made a coffee : patience is a virtue : it finished and got to the login screen and is working fine.

So moral is : even if it looks stuck let it finish... it took mine about 10 to 15 mins - didn’t time it as hadn’t expected it to take so long... perhaps a warning to be patient would help !

  • This may be true, but does not relate to the problem I was having. – oarfish Apr 8 '18 at 7:57
  • How long did you wait for it to restart? – Solar Mike Apr 8 '18 at 8:40
  • It did restart; during the boot screen I waited maybe 5 minutes or so. – oarfish Apr 10 '18 at 10:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .