It seemed that Server.app was interfering with the 10.13.4 update. It would complain that the Server Update required 10.13.4 but offer to install the previous version. Clicking OK for that, but nothing happened and 10.13.4 did not download. Then the update panel stopped populating; it would briefly show the connection spinner, then go completely blank.

A web search showed lots of people having this blank updates problem back in 2013, and at least one person solved it by deleting and reinstalling Server.

I deleted Server, but the reinstall attempt gave me the same previous version offer, but again, clicking OK, nothing downloaded. So I tried hiding it from Purchased. Noticed that Purchased wants me to "accept" GarageBand, Pages, Numbers, Keynote, & iMovie. I clicked Accept, but every time I go to Purchased, it still wants that. Updates is still blank.

Logging out of App Store and back in didn't help. Reboot didn't help. Down loading and installing the Combo update didn't help.

The Manage page won't let me unhide Server.

Trying to re-install Server, they want me to pay for it again!

Searching for an associated plist finds dozens whose names suggest they have something to do with App store. Don't want to delete that many.

Any ideas? I sent a complaint similar to this to the App Store support, but I'm not holding my breath for an answer.

In case anyone gets confused by all that, here are four things wrong:

  1. Updates is blank (it should show Xcode not yet updated and all the “recently updated” items.
  2. “Unhide” does nothing
  3. “Accept” does nothing
  4. Wants me to pay again for Server (4) is minor because I have backups, but (1) & (2) will prevent updating it.
  • Sorry - if you could rephrase this in one sentence - what do you want to do? We're really not app store support and if you can't sign in to the Mac App Store from another clean OS - you won't be able to determine if the problem is with your account or with the Mac. If you have a backup - I'd just copy the Server app from that backup and restart. Do you have any backups of this Mac? – bmike Apr 5 at 0:07
  • Yes, I can restore Server. But I don’t think that will fix the broken App Store. I know SE is not App Store support. It’s also not Q support, where Q is any of the other Apple products discussed here. But it is a lot more responsive than Apple. – WGroleau Apr 5 at 0:12
  • It is and you'll likely get some hints or answers. I was wondering if in all the text you wanted to boil this down to fixing the App Store or something else we might help with. I can't imagine the delay would be long if you emailed support asking them to verify that Apple ID X should have that app purchased or if they could spot you a redemption code to get you urgently back in business. – bmike Apr 5 at 0:29
  • Again, I can restore Server easily. But that won’t fix (I think) any of te three broken App Store features I described. – WGroleau Apr 5 at 0:33

Sadly, the best solution is to isolate the failure. Take your AppleID to a clean install of macOS (you could download the installer and install on to a USB drive or boot to Internet Recovery and see if you can install on to a USB drive.

Then you'll know if the problem is your computer or your AppleID. Despite the delay in getting to Apple Support - they are the one true source of account information and the best troubleshooting and the inside access to engineering to fix your account and/or get you the best chance of a precise fix.

Sorry it's not some easy thing, but the likely cause is you need to wipe and reinstall your Mac and that might only take a couple hours overnight - especially if you have a backup to restore tomorrow. Ideally you would have a second Mac you could borrow and run the test there if you don't want to touch your main Mac or be sure you can restore your current system to a new OS with no issues brought forward with the migration.

  • Sigh. I can remember when we mocked Microsoft for "wipe and re-install" being the first course of action for one app suddenly failing. – WGroleau Apr 5 at 4:52
  • OK, second. They did allow a reboot first. – WGroleau Apr 5 at 5:38

All the problems listed and a few others were fixed by a reinstall from internet of the OS only (no disk wipe) and two subsequent reboots.  (After reinstall, some things worked better but updates screen was still empty until a couple more reboots.)

However, one problem remains that does not show in the UI.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.