0

Every time I open a new iTerm2 window is shown the following warning:

Warning: Use php@7.1 instead of deprecated homebrew/php/php71

Anyone can help me out please?

I've uninstalled PHP, and installed again, and the problem remains.

I've also checked this HomeBrew PHP issue but after I run:

brew untap homebrew/php

I get the following:

Error: No available formula with the name "homebrew/php/php71"
Please tap it and then try again: brew tap homebrew/php

After I run the last command recommended I get again the initial warning.

I have macOS High Sierra 10.13.3.

Thanks in advance.

1

Check your shell config files (i.e. .bashrc, .zshrc, etc.) Chances are, somewhere in there you're calling $(brew --prefix homebrew/php/php71), probably as part of a PATH setting. When you installed php via brew, it provided instructions for setting the path that would have included the above line.

I was seeing the exact same message, and changing this line solved the issue for me. You can change it to $(brew --prefix php@7.1) if you still need it.

  • This was it in my case. – Ilker Mutlu May 9 '18 at 12:09
0

I think your problem is due to using Homebrew for iterm2. Can you just load and install iterm2 from its home page here. If you uninstall iterm2 and load it from home page it should work fine. I say this because I installed iterm2 from its home page and it works fine.

  • Thanks. I've tried that and the problem remains. Also they have the same version: 3.1.5. – foxtrot Apr 4 '18 at 21:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .