13

I have a MacBook Pro 13-inch 2017. My macOS High Sierra has the version 10.13.4 (17E199).

So my problem is that, after the last macOS update, my 2nd external monitor doesn't show the mouse cursor anymore. This monitor was rotated 90°.

What I tried:

  • rebooting
  • making the cursor bigger (read that tip somewhere)
  • when shaking the mouse the cursor is shown in big but the hides again
  • when rotations is set is to default the cursor is there again
  • when in any rotation both external monitors doesn't show the cursor

So anybody has a idea to fix that?

  • 1
    I actually just solved that problem by making the cursor bigger. You need to play with the size. See: discussions.apple.com/thread/8342495 – Mike Apr 4 '18 at 8:37
  • @Mike oh man tried again. had to make it bigger (at least the second line) and leave it that way... that is so stupid. If you would write a short answer i will accept that. – SudoGetBeer Apr 4 '18 at 9:18
4

Installed 10.13.5 release today, and it's fixed!

10

I actually just solved that problem on my Macbook Pro.

Tried all possible solutions. What worked was to make the cursor bigger. However, depending on your screen resolution you will need to play with different sizes.

There is a discussion in Apple forums with more details: https://discussions.apple.com/thread/8342495

  • 2
    I had this exact same issue and one of the users (Pierre) in the discussions.apple.com thread that you linked has the almost the exact set up as me & what Pierre says is reproducible on my end as well. For me, an external monitor connected from USB-C>HDMI & rotated 90 makes the mouse disappear. If I change rotation to standard the mouse will show on the external monitor. Only solution that I am aware of is to increase mouse size above the threshold from System Pref > Accessibility about 3/4 of the way until the first tick mark. -- 2017 MB Pro. High Sierra 10.13.4. 2 Thunderbolt 3 ports. -- – Antonio Apr 14 '18 at 19:05
  • 2
    Increasing the cursor size is only a partial fix. When the cursor changes to text select (e.g. in form fields or terminal window) it will disappear again. – Chan-Ho Suh May 7 '18 at 20:04
  • this doesn't really solve the problem, it's just a workaround. I am quite surprised this isn't' yet patched by Apple. I have exactly the same Setup USB C -> HDMI, 90 Degree rotated screen. – Nour May 13 '18 at 5:06
  • 1
    This works, but I am unhappy that my £2000 mac now has a stupid looking mouse pointer. – superluminary May 31 '18 at 14:29
3

I installed the macOS 10.13.6 beta today, and it appears to have fixed the issue. If it recurs later today I’ll update this answer.

  • Nope - I have the problem with 10.13.6 – Snowcrash Sep 5 '18 at 16:31
  • 10.13.6 (official, not beta) fixed it for me. – Emile Bergeron Sep 20 '18 at 2:16
2

If you make cursor bigger, in the editable mode, a cursor is disappearing again. But if you change the cursor size even more (for me it's almost a half of that bar), it will appear! But the size is so big now, it looks very funny on my screen.

0

Just as @Mike said, make cursor bigger helps, just as follow steps: 1. System Preferences->Accessibility->Display->Cursor size, just drag Cursor size to a little larger and then move cursor to extend display to see whether the cursor is visible now.

  • The problem was fixed for me after installing 10.13.5 (and is still fixed with Mojave) – SudoGetBeer Oct 10 '18 at 9:22
0

have the latest and greatest of OSX and it's still an issue. Pre-Mojave and post-Mojave for me.

A quick command+tab and another back again to the current window fixes it, but this is maddening.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .