1

I was bored one day an thought it would be cool to follow this tutorial to make my Finder windows look like Retro Mac OS Finder http://osxdaily.com/2012/03/20/simplify-os-x-finder-retro-mac-os-classic-style/.

I thought it would add to the effect if I made my Mac Grayscale by going into System Preferences > Accessibility > Display > Use Grayscale.

And then, as usual, I got annoyed by the theme and changed everything back.

Everything switched back nicely including grayscale. But then I noticed that on login, the color of files in Finder Windows and on the Desktop, when selected, was gray, the same color when in Grayscale. See pictures.

Grayscale Unchecked:

Grayscale Unchecked

Grayscale Checked:

Grayscale Checked

What it should be

What it should be

What I've tried so far: - Restart

  • Reset SMC

  • Reset NVRAM

  • Disk Utility First Aid (Permission Errors in Plists)

  • Safe Mode

  • Deleted Bunch of Plists in ~/Library/Preferences

Other Info

I'm running macOS Sierra 10.12.6.

Also, when I change any of the following options it fixes the problem until next login:

  • Accessibility > Display > Use grayscale

  • Accessibility > Display > Increase contrast

  • Accessibility > Display > Invert Colors

  • General > Appearance

My Question: How do I completely stop grayscale so that it remains fixed even after a restart?

  • 1
    Check your selection color and color mode (Blue/Graphite) in General preferences. – SilverWolf Apr 4 '18 at 18:58
  • Unfortunately, that did not work. – JBis Apr 4 '18 at 20:18
  • Well, it half-worked. It looks like a permissions issue—I had a very similar problem. Have a look at this Apple Support article. – SilverWolf Apr 5 '18 at 11:40
  • Disk Utility First Aid won't help with home folder permissions (unless you used diskutil resetpermissions in Terminal). – SilverWolf Apr 5 '18 at 11:43

You must log in to answer this question.

Browse other questions tagged .