9

On OSX Sierra, I can no longer select a Bluetooth Audio device for sound output. I can see the Bluetooth head set is connected and I can select momentarily under Sound Output (see attached screenshot). However, within a few seconds, the Bluetooth device de-selects itself and reverts back to Internal Speakers.

A few notes:

  • I have tried a few different Bluetooth headsets and none pair with my Mac. They pair with my iPhone and other Macs so I can rule out an issue with the headphones
  • I have tried deleting Bluetooth plists and re-pairing. That did not work.
  • I have tried deleting plists related to audio with no luck
  • yes, I've rebooted my computer.

This strikes me as an issue with core audio but I'm not sure how to address this without re-installing the entire OS

soundoutputscreen

8
  • are you sure that the headset doesn't connect to your iPhone instead? I had this problem with one and I had to disable blutooth on my iPhone when I wanted to use it with my Mac, otherwise it would always prefer to connect to the iPhone... – Gio Valerio Apr 4 '18 at 0:19
  • 2
    Yeah, positive. The bluetooth headset does connect to osx but it loses the connection soon after – mcranston18 Apr 4 '18 at 0:52
  • This is crazy. I have a brand new Yamaha Bluetooth receiver - paiurs perfectly with the iPhone, iPad ... but High Sierra reports that it cannot be used for audio output. Looks to be connected, but iTunes takes a while to try and then fails. Anyone having any good luck? – perkiset Jun 26 '18 at 18:49
  • @perkiset this was a nightmare to fix. There was something out of sync between high sierra, the blue tooth driver, and audio driver. I tried re-installing with no luck. I ended up re-formatting my comp. – mcranston18 Jun 26 '18 at 21:22
  • Did anyone found a solution to this? – vaibhavatul47 Dec 8 '18 at 16:31
7

I will add the answer.

Looking through discussions.apple.com, as usual, yields bad advice: reset, reformat, disk cleanup. Essentially do a bunch of random nonsense until the problem sorts itself out.

Before you do anything overly-complex or even irreversible. I recommend you try what I call the monkey's gambit:

  1. Unpair
  2. Forget Device
  3. Pair
  4. Repeat steps 1, 2, 3 a lot

(Look through comments for specific instructions)

Even when it seems like it's doing nothing, keep doing it. It took me 4 or 5 tries. I was nearly convinced it was the hardware, but then all of a sudden I'm back to listening to mediocre music on a pretty good bluetooth speaker.

This might have been expedited if I rebooted my computer, but I really didn't feel like doing that.

TL;DR please do not reformat or reset your computer without running the monkey's gambit for a while; it might save you a more major headache.

To be fair, this worked for me, but it is entirely possible your system is in a state where this will not help it. I do feel compelled, however, to claim that if you can see the device connected in the bluetooth menulet then it is probably not a hardware problem.

2
  • 2
    I wish I could upvote once for the answer and once for the writing style :) – Billy Moon Aug 30 '19 at 9:25
  • Repeating steps 1, 2, 3 indeed helps Big Sur 11.0.1. I notice also that the bluetooth device selector (visible as a radiant mountain icon in the upper right hand corner of Music) seems to a) briefly show a pop up menu that immediately disappears b) disallowing selection and c) corrupts the bluetooth connection for my audio device. Thus, requiring steps 1,2,3 again. I also see this icon in IOS and it works okay there. – John Meyer Jan 30 at 18:47
6

I'm using RHA 650MA headphones and they just stopped working with my macbook. Their name was visible in the bluetooth dropdown, but whenever I clicked connect, it would connect and then disconnect after a few seconds. The headphones never appeared in system preferences -> sound.

Here's the solution:

  • Go to Activity Monitor.
  • Search for bluetooth
  • You should see the following two items:
    1. bluetoothd
    2. bluetoothaudiod (this might not show up)
  • Choose each one and Click X icon to restart it.

Now you should be able to connect!

1
  • No entries pop up for me .. – Siddhartha Mar 4 at 2:42
1

I was able to solve this by quitting launchd from Activity Monitor (Restarting)

1
  • 1
    This restarts the computer, not just the process. Ouch. And, it didn't work. – John Meyer Jan 30 at 18:51
1

I could resolve this issue finally with removing additional audio plugins in the folder /Library/Audio/Plug-Ins.

I don’t know which of the following plugins caused the problem:

  • /Library/Audio/Plug-Ins/Components/AppleAES3Audio.component
  • /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin
  • /Library/Audio/Plug-Ins/HAL/InstantOn.driver (com.rogueamoeba.instanton-agent)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .