8

The Messages app on my Macbook Pro (running High Sierra) suddenly stopped sending text messages to Android devices. I can still send texts to Android users from my iPhone without a problem, but when sending texts from the Messages app on my Macbook Pro it will not send to Android devices. It just started doing this out of the blue yesterday. I have not had an issue until then. And I have not made any updates to the Mac or the iPhone OSs in that time that might cause the problem, but I did install Microsoft Office 2018 on the Mac. Cellular data is turned on on my iPhone as is Send as SMS.

  • 5
    The operating system of the recipient 's phone doesn't matter when you are sending an SMS. – Nimesh Neema Apr 3 '18 at 16:15
17

Text messages from your Mac are actually sent through your iPhone. On your iPhone go to the Settings app → Messages → Text Message Forwarding. You may need to re-do the setup by removing and re-adding your Mac in there.

| improve this answer | |
2

I fixed this by enabling the following setting on my MacBook:

MacBook > Messages > Preferences > iMessage > Settings > You can be reached for messages at: > Check checkbox next to your phone number

enter image description here

| improve this answer | |
0

I don't have the iMessage icon. I have an Account icon instead. The inability didn't happen until I updated my iPhone 11Pro Max a couple of days ago. I updated my iPad Air 2, can still send; I updated my iMac to Catalina, no problem; my Apple Watch sends them without problems, as well.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .