0

I created 2 iCloud email aliases a year ago, but didn't end up using them so deleted them from my iCloud mail preferences. On my iPhone though, if I select "send mail from" those aliases are still there, whereas if I log into iCloud web mail they aren't.

Is there any way to get rid of them on my iPhone (running iOS 11.3)?

1

UPDATE: I just needed to sign out and in to get rid of those aliases.

0

This is kind of an old thread, but I had the same problem and couldn't find any answers online, and I managed to fix it on my own. For me, not only was an old alias showing up on my iPhone, but a new alias I had recently created wasn't showing up and I wasn't able to send from it.

Go to Settings > Passwords & Accounts > iCloud, and at the bottom under 'Advanced' click on 'Mail'. There you'll see 'Allow Sending From,' where you should see the old alias(es) and can disable them.

After clicking 'Done' and closing and reopening Settings, the old alias(es) should be gone and any new ones should be there.

  • Forgot about this thread already. My problem was that I didn't want to disable them, I wanted them gone forever because they were DELETED thus shouldn't had been in the list at all. Signing out of iCloud on both iPad and iPhone sorted the problem out as they were gone completely. – Kerberos Dec 22 '18 at 0:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .