10

As can be seen: mactex was installed successfully:

==> Installing Cask mactex
==> Running installer for mactex; your password may be necessary.
==> Package installers may write to any location; options such as --appdir are ignored.
Password:




==> installer: Package name is MacTeX-2017
==> installer: Upgrading at base path /
==> installer: The upgrade was successful.
🍺  mactex was successfully installed!

Where is it however..

21:22:37/hw6 $which tex
21:23:35/hw6 $which mactex
5
  • 1
    brew cask installs binaries into /usr/local/Caskroom/ . Could you check that? Apr 3 '18 at 8:15
  • @MateuszSzlosek Well there's a /usr/local/Caskroom/mactex/20170524/mactex-20170524.pkg .. but there are no binaries anywhere (did a find / -name tex and also find / name mactex ..) Apr 4 '18 at 4:02
  • Mactex is a graphical application, so probably "MacTeX.app" is located somewhere in /Applications/. And the binary is probably in MacTeX.app/Contents/MacOS/ Apr 4 '18 at 5:26
  • oh there's a TeX app .. let's see what's in there.. Apr 4 '18 at 5:30
  • i'ts TexLive which is something different.. I can't get any joy on Tex it seems Apr 4 '18 at 5:31
7

At the time of writing (June 17th, 2018) running:

brew cask install mactex

will install MacTeX-2018 and

which tex

gives

/Library/TeX/texbin/tex
3
  • doesn't work like that for me. same problem as op.
    – tesch1
    Aug 29 '18 at 13:37
  • 3
    oh, after starting a new shell it's there.
    – tesch1
    Aug 29 '18 at 13:37
  • As of September 2018 it now works (as mentioned in my own answer that had not been the case in April). Oct 8 '18 at 20:31
1

Perhaps this is answer is unrelated to the issue the OP had, but I found the question while I was having a similar issue. While reinstalling MacTeX, I noticed this message:

==> Caveats
You must restart your terminal window for the installation of MacTex CLI tools to take effect.
Alternatively, Bash and Zsh users can run the command:

  eval "$(/usr/libexec/path_helper)"

Sure enough, after running that command, I found tex in my path:

$ type tex
tex is /Library/TeX/texbin/tex

And starting a new terminal window also solved the problem for me.

0

In April I had installed/reinstalled multiple times without success.

Bu I reinstalled via brew cask reinstall mactex in Sept 2018 and the issues no longer appeared: mactex worked. Maybe something were resolved in the binaries.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .