4

So at some point last year I set MacOS language to my native language. I didn't quite like it, so after a while I switched back to English. Since then, MacOS keeps sporadically showing me messages in my native language, usually in low level scenarios (during startup, shutdown or update, in some system dialogs like Disk Utility repair disk log, etc.).

I tried every solution I could find (re-add and remove the other language, do it in safe mode, set English as default through the terminal, etc.) with no luck. Messages in my native language keep popping up from time to time. The weird thing is that the same message (like in the attached photo, which shows the restart computer dialog window) will sometimes be displayed in English, sometimes in the other language, with seemingly no logic as to why.

Does anyone have any idea how to fix this? Thanks!

MacOS shows system dialog windows in wrong language

1

Had the same problem today. I've opened the terminal and ran the following command:

$ sudo languagesetup

  • You'd have to add the password from your Mac's user.
  • You'll be prompted with a language list.
  • Select the one you desire, restart your Mac and just in case disable the option to reopen windows when you log back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .