This morning I updated macOS High Sierra from 10.13.3 to 10.13.4. It appeared to install fine (I got to the login window), so I clicked on "Shutdown", and when I got to the office, and turned on my Mac, it rebooted into recovery, with the Installer Log open, and a dialog that read, "The macOS Installation couldn't be completed".

I called Apple and they had me run a check disk, and the boot-up volume didn't have any error. My internal SSD showed up just fine, unlike what happened to this poor chap. Apple also had me try to restart in Safe Mode, but the Apple icon got stuck at 100% progress (3+ minutes waiting).

So, since my drive appears to be intact (I used Terminal to browse my data), is it possible to undo the update or reinstall macOS High Sierra and have the system work as it was before the update (apps and data still accessible)?

Note, I use Time Machine backups, and I have a 2TB drive with about 40% free space. There are lots of "snapshots" on the volume. Is there a way to recover the system to the Time Machine snapshot taken before each update? Or, will I need to reinstall macOS High Sierra?

Since posting this, Apple called me back and they said that I should be able to reinstall macOS Sierra without formatting the drive and I should be back to the state I was before the failure. I haven't tried this yet as I wanted to see if others have followed this or another procedure to recover from this failure without blowing up the hard drive and starting from scratch.

  • 1
    Also experiencing this issue on a Macbook Pro 13" 2018 model Commented Apr 3, 2018 at 4:06
  • 1
    This is my second osx update in a row thats gone wrong. :( late 2016 MBP
    – Stephen
    Commented Apr 14, 2018 at 10:35
  • This is really a duplicate of an older question, however having an accepted answer and better answers here makes me hesitant to close this as a duplicate - apple.stackexchange.com/questions/243828
    – bmike
    Commented Dec 27, 2019 at 15:13

11 Answers 11


Fortunately I was able to simply reinstall macOS High Sierra by booting into Recovery Mode (Command ⌘ + R) and choosing Reinstall macOS High Sierra.

I did not erase my drive first since system volume was intact (no errors after running Disk Utility). I simply reinstalled the OS and I was able to log back in with all my data, settings, and apps still there just like before.

Also, this installed the 10.3.4 version of macOS High Sierra, so I don't have to go through the update process again.


At the installation log, I clicked on startup disk and chose Macintosh HD and restarted. The system successfully booted into 10.13.3. Now I'm trying to update the OS from the App Store again.

  • 3
    This does not make any sense and it worked like a charm. Does anyone understand what the heck is going on?
    – Atcold
    Commented Dec 31, 2018 at 15:51
  • this worked for me as well, because if the older model box. I then when and installed the new update through the app store. no data loss! Commented Feb 27, 2019 at 3:57
  • This worked, and it was quick. Would suggest trying this as the first thing.
    – Rans
    Commented Jun 21, 2019 at 18:03

One thing that worked for me was holding down the Option key and selecting the original partition to boot into. Then downloading the update directly from Apple and installing it.

macOS High Sierra 10.13.4 Combo Update can be downloaded here.

  • Great suggestion! Was getting disk write errors, restarting and holding Option key during bootup fixed boot issue where update didn't apply. I was able to re-apply the update, suspect maybe a corrupt download patch or low battery issue. Commented May 22, 2018 at 14:10

I had the same problem (15-inch, Late 2016 MacBook Pro). I was able to fix my issue without losing data by running First Aid (from Disk Utility) when the laptop was in the crashed state. Once First Aid completed the pass on the drive, I simply rebooted and the OS loaded successfully.

  • 2
    I had the same success on my 2017 MacBook Pro 13". Commented Apr 3, 2018 at 4:31
  • same here, it appeared as tho the First Aid did nothing, but it booted after
    – manroe
    Commented May 30, 2019 at 0:14

I had the same problem with the update to 10.13.4. I was able to boot to Safe Mode (hold Shift during power up) and then restart normally into 10.13.3.

For now I'm happy with 10.13.3 and I hope that the update will be patched in the near future.

I hope this might help.

  • 1
    Thanks Henry. That was one of the things Apple ask me to try as well, but the progress bar got to 100% and the login screen never appeared. Did you have to wait an extended period for the Login screen to show? Commented Apr 2, 2018 at 17:18
  • Yes, it does take a few minutes but boots successfully in safe mode.
    – atulkhatri
    Commented Apr 16, 2018 at 7:11

In the past I have used a procedure for upgrading macOS versions that I had good successes with, especially when discussion groups and news are seeing problematic installs: using a system cleaner.

EG using something like Onyx before installing, then a reboot and proceed with the install. Yah, too late now for you but something to consider for the next time.

If the restarting in Safe mode doesn't do the trick (it may...) If I were you I would use Recovery Mode and restore from a Time Machine backup. If I remember correctly you have the ability to restore from a specific point in time.

  • Thanks Steve. I'll look into that for future updates. I want to avoid a Time Machine avoid as I have over 1.2TB of TM data, and in my experience, you lose data each time you do this (permission issues, bit rot, etc.). Commented Apr 2, 2018 at 17:21

I had the same problem (15-inch, Late 2016 MacBook Pro). What I did first was to enter the safe mode (Shift when starting the apple) try to download the update but I had the same problem again, then try to enter Recovery Mode (Command ⌘ + R) and set my startup to be my disk "Macistosh HD " by default, I restarted and the error message not appeared.

  • Worked for me with the High Sierra 10.13.6 update
    – Martin
    Commented Apr 4, 2019 at 13:34

Same issue here. I was under the impression that I was running 10.13.4 but after a restart was presented with the same Installer Log error screen. I was able to reinstall macOS High Sierra (Command ⌘ + R at boot) without needing to wipe my drive and my data and settings were retained and I was successfully updated to 10.13.4.


Same problem; installation of 10.13.4 failed with 'could not be completed'. I booted into recovery mode, ran disk utility repair and tried again after restoring from backup. Still no joy, and disk utility is now reporting lots of 'invalid internal_flags'. Finally I restored again and I'm sticking with 10.13.3.

Checking the fsroot tree.
warning: inode_val: object (oid 0x5edb): invalid internal_flags (0x48000)
warning: inode_val: object (oid 0x5edb): invalid pad2 (0x2a)
warning: inode_val: object (oid 0x5ee1): invalid internal_flags (0x48000)
warning: inode_val: object (oid 0x5ee1): invalid pad2 (0x2a)
Checking the snapshot metadata tree.
Checking the extent ref tree.
Checking the snapshots.
Checking snapshot 1 of 3.
Checking snapshot 2 of 3.
Checking snapshot 3 of 3.
Verifying allocated space.
The volume /dev/rdisk1s1 appears to be OK.
File system check exit code is 0.
Restoring the original state found as mounted.
Operation successful.

I had this problem on a 15" 2017 MacBook Pro. I was able to solve it by entering Recovery mode, mounting Macintosh HD (it was unmounted), checking it with First Aid, then restarting the computer and downloading the update.


I got exactly the same problem: after 8-9 minutes got the message to restart because the update didn't work. I had the same with the previous update, but didn't learn my lesson. Then I downloaded the update and with the dmg file managed to update. Mistakenly I didn't this time.

So, first I restarted in safe mode, which worked, but when I restarted again back in normal mode, I got the same problem.

Then I restarted with the space bar. Didn't work. Same problem.

Then I restarted in recovery mode, and that finally worked. However, regretfully my most recent time machine backup was 2 weeks old (I was traveling), meaning I lost 14 days of work.

For the past hour I have been trying to download the dmg file instead of using the update via apple store. First attempt, the download got stuck at 577KB; second attempt stuck at 4.1MB.

So, now I decided to wait & see and ignore the apple store message to update, until I read some good news.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .