I have a MacBook Pro Late 2014 model. I decided to do the update to 10.13.4, the incremental update to 10.13.3. It gets everything downloaded and does the reboot. I get to a gray screen and it sits for a long time and finally states "installer resources not found" and asks me to reboot and try again. Even when I try again, this process repeats.

This is what I've tried so far:

  • Resetting the SMC and NVRAM
  • Boot into recovery (1)
  • Single user mode (2)
  • Boot menu and choose "Macintosh HD" to boot back into my system (3)
  • Boot a Linux Live USB Image (4)


When I got to recovery, the first thing I decided to try was to look at disk utility. My drive does NOT appear. I then decided to go and try to "reinstall" macOS. It shows my 500gb drive, but the icon isn't a drive, it just looks like the generic paper icon and states that I don't have enough free space to install.

I opened a terminal and tried to view the file system. It hangs. Screen

Single User Mode

I noticed in the kernel messages that disk2 'media is not present' - /Volumes is empty.

Boot Menu

When I go to the boot menu, I can see the macOS installer option (which takes me back to the original problem of no installer resources) and then Macintosh HD. When I choose the latter, I get to my login screen (yay!) except when I login, if I can, the system eventually hard locks with the spinning pinwheel and I can't do anything else at this point.

Live Linux Image

I tried a live linux image just to see if I would get similar errors in dmesg, but I don't. I can mount the EFI partition fine. Of course, since Linux doesn't have APFS support, I can't mount that. So nothing I can do there. It was just a simple test.

I took my Mac to an Apple store to have them to their diagnostics. They saw the same things - essentially their tests showed the hard drive being in a good state and everything being OK. But clearly it isn't. I'm assuming the drive is dead.

Is there anything else I can do to further confirm if the drive is dead or not? I do have my data backed up. I would like to see if there is anything else possible, assuming that I may end up having to buy something from OWC anyway.

Edit: The drive has bad blocks. macOS images refuse to install to the drive, no matter how the partitions are formated (HFS/APFS).


6 Answers 6


I had a similar problem with the 10.13.4 update. It failed to install and booted into Recovery Mode where the Console showed a file not found error in the logs and a menu to shutdown or restart. If restarted the system would again try to install the update and then fail the same way, resulting in a loop. Here is how I managed to fix it.

First I booted into Safe Mode (hold shift while booting) and started the update again from the Mac App Store. But this didn't succeed and the same problem appeared. I then booted again into Safe Mode, but this time deleted the folders which contained the update files which caused macOS to attempt to install the update every startup. These are the two folders I deleted

/macOS Install Data

This requires admin privileges. The easiest way is via the Terminal command sudo rm -rf /path/to/folder (Warning: Be sure that the path is right, otherwise you might delete your files. In any case make a backup of your drive first!). And even then it will tell you it can't delete all files in those folders because some are system protected but this is enough to solve the problem.

After deleting these folders I was able to boot up normally again although the system showed it was still on 10.13.3. I restarted the update in MAS again which then installed properly.

  • 2
    Thanks, deleting the /Library/Updates folder solved it for me.
    – Stan
    Commented Apr 5, 2018 at 8:34
  • Deleting /Library/Updates via Finder worked fine for me. Commented Dec 31, 2018 at 22:34

My 17" MacBook Pro, late 20011, had the same issue with the 10.13.4 update. I finally tried safe mode, (hold down Shift key until login). This took a few minutes. That allowed me to log in. The system then went back to the boot up screen, and then took more than 10 minutes to actually finish installing. That worked for me, as it's now back to normal.

  • Same scenario for me. I tried remove all USB devices / external display and I wasn't able to login. Just after boot in safe mode and select Restart on specific disk it worked.
    – Lucas
    Commented Apr 2, 2018 at 16:28
  • 1
    I have the same problem here, I tried to boot into safe mode and reboot, but it doesn’t work for me. Commented Apr 2, 2018 at 19:34

I have several times updated macos 10.13.3 to 13.3.4 but always failed on installation. At the end I downloaded whole high sierra 10.13.4 and installed. Done, all OK.

  • Likewise. Both the 10.3.4 and 10.3.6 updates from the App Store failed to install. This reminds me of the old days when I used to sit on the forums after every OS release helping people get back up and running after the installer broke their systems. Did somebody revert to the installer from 10.3 or something? The combo update is installing now. Then again, the 10.3.4 update looked like it was installing, too, until it failed to boot, and I changed the boot volume back to the root disk and got 10.13.3 again, so ¯_(ツ)_/¯.
    – dgatwood
    Commented Aug 19, 2018 at 2:48

Yes - you should go through the erase / install procedure to repartition the drive. That seems like something the Apple store would have reviewed, but maybe it took more than the 15 to 20 minutes allotted to try some quick fixes.

Basically, don’t try terminal or mount - just wipe the drive and start over with a clean partition map. Your “tried so far list is good” since one SMC/NVRAM reset is plenty and unlikely to help in this case, but you ruled that out.

All the other items are not very good other than booting to a recovery HD or a createInstallMedia installable USB or internet recovery. From there, you should be able to erase / repartition / set up a clean drive.

  • Disk utility does not show my drive at all. So trying to erase the drive doesn't seem like it's going to happen without another way of doing such that doesn't involve Apple utilities. I'm sure it's related to the dmesg messages saying disk2 media is not present. It's either that, or the drive is for sure dead and needs to be replaced.
    – Sokel
    Commented Apr 1, 2018 at 20:07
  • 1
    If you bring a known good OS to the machine - that disk utility needs to see the drive or you have hardware issues. Sorry about that - I was hoping you could get things going with a procedure.
    – bmike
    Commented Apr 1, 2018 at 20:45

Try doing internet recovery mode (Similar to recovery mode - CMD+R+Option) and see if it can detect your hard drive this time.

If not then you may want to take it in to an ARS so they can detect why its not able to be detected by disk utility.


Had the same issue, kept ending up in the macOS Installer utility. Re-installing from App Store in Safe mode gave the same issue. Selected startup disk from the macOS Installer menu and booted into 10.13.3. Using the browser downloaded the full update. Hope that helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .