2

How can I go about requiring an admin password when changing Wi-Fi networks on Mac? The auto-connect/preferred list sometimes connects to a lower priority network without my knowledge.

  • 1
    I don’t think this will work. If you have trusted the network and allow it to auto join - the system is free to see a moment when there’s interferenace on your preferred network. The real fix is to not allow the other networks in the first place. – bmike Apr 1 '18 at 16:37
1
  1. Go to System Preferences → Network preference pane.
  2. Unlock the pane using the lock button in the bottom-left and authenticating.
  3. Choose Wi-Fi in the services list, or whatever you called your Wi-Fi service.
  4. Click Advanced….
  5. Enable ‘Require administrator authorisation to: Change networks’.
  6. OK and Apply.

  • Thank you! I have it on and its not asking for a password to change networks, anything you recommend there? – Nullogy Apr 1 '18 at 16:32
  • @Nullogy That's odd, have you tried restarting? Even logged in as an administrator, I get a prompt to change network with this enabled. – grg Apr 1 '18 at 16:34
  • 1
    This is likely an XY - the OP is asking but when you get him set up with an admin access - it still won’t prevent roaming / renegotiation to the less preferred networks 100%. This will either be - show the network name prominently so the OP can see it’s swapped or remove the trust from the secondary networks. – bmike Apr 1 '18 at 16:38
  • I just tried restarting and no-luck, I even added "require password to turn wifi on/off" and it didn't prompt me. Could it be update related? – Nullogy Apr 1 '18 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .