5

The Photos app on my Macbook hasn't been syncing for a while, ~6 months. I just came from holidays and added photos from my camera to it and again, nothing. Photos is stuck at "Uploading..." but there is no network activity.

Some facts:

  • I have a Mid-2014 Macbook Pro
  • battery health: 82%, cycles: 209, condition: normal
  • MacOS High-Sierra 10.13.4 (updates in the past didn't help)
  • I'm on a wired 1gb fiber connection (8ms ping, down: 880, up: 470)
  • Fully working iCloud photo library across my iOS devices with more than enough free space

What I have tried:

  • deleting ~/Library/Containers/com.apple.cloudphotosd/Data/Library/Application Support/com.apple.cloudphotosd/ and killing cloudphotosd
    • It does rebuild the index and re-syncs shared albums, those always work
  • Resetting the Macbook SMC & PRAM
  • Fresh install of MacOS, reimport photos from scratch

The actual problem:

The console logs the following which seems highly relevant:

502:com.apple.cloudphotosd.pending-work:509E84:[
    {name: ThermalPolicy, policyWeight: 1.000, response: {Decision: Must Not Proceed, Score: 0.00, Rationale: [{thermalLevel >= 1}]}}
 ], FinalDecision: Must Not Proceed}

Since I have tried so many different software things this makes me think that the system thinks the battery is bust (or some other thermal thing, like CPU temp, which is actually normal ~140F).

Can anyone think of anything else that I should try? Apart from replacing the battery / taking the laptop for service.

  • I'm having the same issue. If I kill off all the other apps/background tasks then I can usually get it until it passes whatever thermal test it is applying. Even then though, it syncs extremely slowly, using basically none of the available network capacity. – andynormancx Sep 11 '18 at 14:34
1

The short answer is you want your Mac to get out of CPU use so that iCloud photos will resume. Thermally cooling the case and/or quitting all other processes that use CPU would be warranted.

Since you're technical minded - you can dump the thermal stats to see if you feel you have a hardware issue or can shape the workload to relieve a proper thermal pressure warning:

 pmset -g thermlog

The long answer is there are many throttles and other things that could go wrong with iCloud upload. Look at this reverse engineering of things in the plain files portion of iCloud file upload - let alone the more detailed Photos use that does face, moment, web app and more features in play like daily upload caps, uploads to shared storage being different than your iCloud storage and optimizing the versions when you run low on storage space.

enter image description here

Diagram from the amazing article by Howard Oakley - https://eclecticlight.co/2018/03/30/inside-icloud-drive-uploading-a-file/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .