16

I have an early 2015 Macbook Pro running Mac OS Yosemite. Last year I replaced the Mac's internal 500GB SSD with a OWC Aura 1TB SSD. Everything has worked fine up to now, although the OS still recognizes the SSD as an "external" drive.

I am now trying to upgrade to High Sierra. The installer won't run on this drive, complaining that that it's missing a firmware partition.

installer screenshot with message

I'm not sure if this is related to other posts (e.g.) I've seen about OWC SSD drives installed internally but appearing as external. Or, if it has to do with attempting a three-version leap in the OS.

I have an external Time Machine drive with a recent backup, so I guess I could attempt reformatting the OWC drive, installing High Sierra, then restoring from Time Machine. But that takes so long I'd like to avoid it if I can. Also, if the fault is in the drive itself I'm not sure it would work. Anything else I should do?

Update: I have spoken with OWC customer service, and they say I will need to reinstall the OEM SSD. Then upgrade to High Sierra, which will update the Mac's firmware. Then re-install the OWC drive, and upgrade that to High Sierra. I hope I can find the old drive...

  • The procedure you outlined in the update worked for me, thank you. – Noor Apr 4 '18 at 22:19
  • Did your solution work? I have the same issue. – James Apr 5 '18 at 23:52
  • @James: Not yet. I'll post an answer when I'm there. – Matthew Leingang Apr 8 '18 at 23:34
6

I finally did get this to work. Here is my process with the non-functioning loops edited out. It's inspired by, but slightly different from, this process outlined by MacSales in How to Format a New Internal SSD in macOS High Sierra.

For this process, you need not just the original (OEM) Mac SSD, but also the enclosure that OWC sends with their upgrade kit. The screwdrivers (P5 and T5) come in handy too. And a spudger tool, sold separately. Also, this process wipes both the original and the new (OWC) SSDs clean, so you need a recent backup, for instance Time Machine.

  1. Open up the Macbook, and replace the OWC SSD with the OEM one.

  2. Boot into recovery mode (command-R at startup). Use Disk Utility to erase and reformat the internal drive, and install a clean macOS on it. It will be an old version; in my case Yosemite.

  3. Reboot, and using an administrator account, install macOS High Sierra on the OEM SSD. You now have High Sierra, but on the wrong drive, and none of your data.

  4. Open up the Macbook again and remove the SSD. Install the OEM SSD in the external enclosure, and the OWC SSD in the MacBook.

  5. Plug in the external, reboot, and hold down Option at the chime. You will have the option to boot from the internal (OWC) SSD into the old MacOS version, or the external (OEM) SSD into High Sierra. You want the latter. It will slow down a bit, but it will work.

  6. Use Disk Utility to erase and reformat the internal (OWC) drive.

  7. Go to the Mac App Store and redownload the "Install MacOS High Sierra" application. It should be about 5.2GB large. Run the installer, and use it to install High Sierra on the internal drive. Remember, everything's running off the external drive with the OEM SSD. You now have High Sierra on both drives.

  8. Use the Migration Assistant to restore your files from the Time Machine (or whatever) backup back to the Mac. Repeat with any other backed-up data not stored in Time Machine (e.g., Dropbox, Box, Google Drive, etc.)


The linked article says that you can replace steps 5–7 by booting into Internet Recovery Mode (option-command-R at startup). I believe this is what OWC told me in tech support chat, too. The idea is that upgrading the OEM SSD to High Sierra will update the firmware, so that internet recovery mode gives the option to install High Sierra. That didn't work for me; I could only install Yosemite in Internet Recovery Mode. If it did work, I would not have needed the enclosure, since I wouldn't need two SSDs running at once. One of the commenters says it worked for them, so maybe I screwed up.

Also, you may wonder why you can't skip step 4, put the OWC SSD in the enclosure, boot from the internal OEM SSD, and install High Sierra on the external OWC SSD. I tried this several times, and it would error out at various stages. There is a sticker inside the enclosure that says "Mac SSD only". I finally believed it.


At least this process eliminated an annoyance that I had when I originally installed the OWC SSD. Even though it was installed internally, it showed up in the operator system with an orange "external drive" icon. I think this is part of the reason the update process was so complicated—the Mac knew this drive was an impostor of sorts. But now it's got the same icon as the original one.

--

Edit 2018-04-13: OWC has published a firmware update (beta as of this writing) for their OWC Aura 6G SSD's which purports to deal with this very issue. Thank you to new user mauple for this suggested edit. It would have been nice if tech support had alerted me to this beta at the time I contacted them, since it did exist.

  • Did the installer block you from the get go? The installer did not block me originally. It ran the update, restarted the PC - but went to recovery mode, complained about missing files for the OS update, forced restart to fix, then said that it didn't know what it was supposed to be doing. Now I stall on startup and can only boot into recovery. – kando Jun 19 '18 at 16:12
  • @kando The update went far enough to bring me from 10.13.3 to 10.13.4. So I can't reinstall current version, since 10.13.4 has the above issue. 10.13.4 and beyond (update to latest version) doesn't work because "third-party storage" isn't allowed. I can't factory install the original OS because it isn't compatible with APFS. I do not have my OEM hard drive anymore. I placed someone else's OEM hard drive (same exact model..) in and updated to latest version (10.13.5 by then, I think), then attempted to update my OWC drive to latest version. No luck - third party storage still not allowed. – kando Jun 19 '18 at 16:16
  • @kando I bought an external and dumped the internal contents onto it, then wiped+formatted my OWC internal drive. No luck - third-party storage still not allowed. (I do NOT want to buy another enclosure for this fix. I gave the OEM in the enclosure away, but no one knows who took it.) – kando Jun 19 '18 at 16:22
  • @kando Next step: Start friend's PC while holding T key (for target disk mode). Connect via USB A 3.0 male to USB A 3.0 male. Boot using friend's PC in "enclosure mode". Run firmware update from this mode, and if not run macOS update from this mode. And if not, format to HFS+, install factory OS, install firmware, update to latest version. – kando Jun 19 '18 at 16:22
  • @kando: I feel your pain. The installer blocked me from the get-go. It looks like you're developing your own answer for this question. Good luck. PS It looks like enclosures can be bought online for $10–$20. – Matthew Leingang Jun 19 '18 at 18:24
6

After struggling with this for a very long time, and not having access to the original HD as that broke, this EDIT and OWC Support helped.

There is a firmware update from OWC, which is in beta (not always stable, worked for me all 3 times), that you can find here.

You'll be prompted to download the Firmware Update (as of writing 2.3.15.1067) and the installer.

When the installer is downloaded, you'll be prompted to do those steps:

  1. Log In with your Mac Username and Password
  2. Select Adapter 0
  3. Select Operations
  4. Click Update
  5. Select The File You Downloaded
  6. Restart Your Mac
  7. Repeat The Steps and Click Update To Make Sure The Newest Versions Was Installed (2.3.15.1067)
  8. Install The MacOS Update

Thank you to support and this answer for solving the problem and hope that helps :)

  • This worked for me. The instructions on the OWC website were confusing. After downloading the msu.dmg, and running the installer, it will install an application called "MarvellTray" in the Applications folder. You need to run that. – dsgrnt Jun 16 '18 at 20:15
  • Yes, OWC has finally made a software update available, and it works great. – vy32 Sep 28 '18 at 15:48
  • I can't see the update button when logged in via marveltray Under adapter 0 and operations it's not listed. – iTris Oct 12 '18 at 11:16
  • What the firmware update appears to do is make the drive appear (appropriately) as internal, rather than external, so the High Sierra/Mojave installer performs the appropriate firmware updates. However, more excitingly, the utility actually allows you to completely remove the RAID 0 and instead expose the two underlying 480 GB drives. Superficially, I feel as though I'm getting more battery life this way, and my 2015 MacBook Air now comes out of hibernation (full battery drain) properly, though that was on the firmware fix list, so I don't know if that's part of the non-RAID config or not. – Ivan X Nov 17 '18 at 16:36

You must log in to answer this question.

protected by Community Apr 6 '18 at 0:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .