My OS X Yosemite 10.10.5 Mac seems to only be able to hit HTTPS URLs, but not HTTP URLs. I tested another computer on my network, and that machine seems to work fine.

I tested using this URL: http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js

In Chrome, the URL returns ERR_EMPTY_RESPONSE. Safari and Firefox return similar errors.

With curl, curl -4 http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js works fine, but when I do either of these…

curl -6 http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js
curl http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js

…I get:

curl: (52) Empty reply from server

I changed my DNS to and to use Google's DNS instead, and flushed my DNS cache using sudo dscacheutil -flushcache;sudo killall -HUP mDNSResponder; and restarted the machine, but it still ends up with the same issue. It also fails on other sites that use HTTP, such as http://yahoo.com.

If I change HTTP to HTTPS on any of the above URL's, it works fine.

  • I don't see this as a DNS issue as the error you're getting (52) means that it connected to the server but there was no reply from it. The fact that it works when you force IPV4 (curl -4) but not using IP6 (curl -6) or default points to a problem in your network infrastructure like a firewall, a proxy, or a router that's preventing your connection. – Allan Mar 31 '18 at 17:41

I've experienced the same behavior twice, Once with Time Warner and again with Comcast Xfinity. Browsing to HTTPS is fine, HTTP is empty response.

In both cases I contacted the ISP and they resolved it. It's possible some site tripped an upstream alarm.

See here for similiar experience

| improve this answer | |
  • This is definitely a computer issue. I tried a bunch of other devices on the network, and none had this problem. I tried logging in as other users on this computer, and the problem still persists. – RobKohr Apr 2 '18 at 16:06
  • Does it work if you spoof your Mac address for the affected computer? – Timmy Browne Apr 2 '18 at 16:09
  • 1
    I tried the mac on another network, and it worked, and when I came back it didn't. Restarted the ATT broadband modem, and now it works, so it looks like yeah, it was something on the network was the issue. It is funny it only affected just one computer. – RobKohr Apr 2 '18 at 20:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .