2

I am using a Retina iMac 5K running Mac OS X El Capitan connected with a Apple A1843 wired (USB) keyboard with F1 thru F19 and numpad.

I expect (as per icons on key-tops):

F1 dim brightness F2 brighten F3 mission control F4 multiple windows ...etc... F10 mute F11 sound quieter F12 sound louder, and F13 - F19 not assigned

What I get:

all F keys do nothing, except F14 (old F1, dims screen), and F15 (old F2, brighten), regardless of state of fn modifier key.

A complication:

I cannot get the function keys at top of the keyboard to work as advertised, even with the modifier keys (fn, control, shift, option, command). I tried to check the box for Use F1, F2, etc. keys as standard function keys under System Preferences → Keyboard but the option is missing.

screenshot of Mac dialog

A test of key scans:

I ran the xev program in XQuartz (X11) environment and verified that the system is responding to keypresses on the function keys (see comments).

Q: How do I reset the function keys to do what they advertise?

  • What steps have you tried so far to fix this? Also, is this the keyboard that came with your iMac? – Jake3231 Mar 30 '18 at 22:50
  • I have tried different kbd combinations and rebooting. The keyboard is an Apple kbd but it did not come with the iMac (which uses a Bluetooth one). – Eric O Mar 31 '18 at 0:03
  • Have you attempted to use a different wired or wireless keyboard? – Jake3231 Mar 31 '18 at 0:06
  • Those keys may not be functioning. See this post for a way to determine if macOS is seeing the key presses. – Allan Mar 31 '18 at 0:08
  • @Allan I installed XQuartz and ran the xev command as specified. The system sees F1 thru F13 but has no symbol for F14 thru F19. – Eric O Mar 31 '18 at 0:27

You must log in to answer this question.

Browse other questions tagged .