1

I am trying to install php71 with the command brew install php71 but instead php@7.1 is installed.

When trying to install redis with brew install php71-redis it's installing but not working with that php@7.1.

macOS High Sierra 10.13.3

also sometimes still get this warning: Warning: Use php@7.1 instead of deprecated homebrew/php/php71

  • What exactly is ‘not working’ with installing redis? Do you get an error message? ‘php@7.1’ is the canonical name for PHP at version 7.1, this is expected and correct. – grg Mar 30 '18 at 12:15
  • usually I have php71 folder in /usr/local/opt/ and i was having also php71-redis and so on.. now i have php@7.1 folder and php71-redis and redis is not runing.. on this php@7.1 version. – Scorpioniz Mar 30 '18 at 12:21
0

Found my answer! After this update (brew) we need to install pear (pecl) for installing extensions for php.. so i.e. redis extension was installed pretty easy like pecl install redis But need to be set correct php version that pear (pecl) would found where to install extension.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .