3

I'd like to use Conkeror as default browser in Mac OS 10.6. Selecting conkeror.app as default browser with Safari does not work. While it is possible to start Conkeror via Firefox command line arguments (-app), opening additional URLs with that instance is not.

If anyone has been able to setup Conkeror on Mac OS 10.6 in a way that...

  • uses Conkeror as default browser for all applications
  • reuses a running Conkeror instance when opening an URL (either current or new buffer)

..., could you post the steps necessary to do so?

P.S.: Feel free to retag with 'conkeror'

EDIT: In addition to the Info.plist solution posted below, you also need the line

url_remoting_fn = load_url_in_new_buffer

in your .conkerorrc, if you want to open URLs in an existing window.

2
+50

Sure it's possible to set Conkeror as the default web browser; it just needs a properly structured Info.plist file.

I created one here: http://www.markdouma.com/developer/ConkerorInfoPlist.zip

Just download that, unzip it, and replace the following Info.plist file with the one included in the download:

/Applications/conkeror.mozdev.org/conkeror/Contents/Info.plist

Note: after completing this, make sure you touch the application bundle, which will force Launch Services to re-examine and re-register the app and its newly found capability for the http:// and https:// URL types. In other words, the following should be sufficient:

touch /Applications/conkeror.mozdev.org/conkeror.app

Then deselect and re-select the app icon in the Finder.

Launch Safari, and choose Conkeror from the popup menu:

enter image description here

FWIW, I changed the Info.plist to be the following:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
    "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>CFBundleSignature</key>
    <string>CONK</string>
    <key>CFBundleIdentifier</key>
    <string>org.mozdev.conkeror</string>
    <key>CFBundleURLTypes</key>
    <array>
        <dict>
            <key>CFBundleURLName</key>
            <string>Web site URL</string>
            <key>CFBundleURLSchemes</key>
            <array>
                <string>http</string>
                <string>https</string>
            </array>
        </dict>
    </array>
    <key>CFBundleInfoDictionaryVersion</key>
    <string>6.0</string>
    <key>CFBundleDevelopmentRegion</key>
    <string>English</string>
    <key>CFBundlePackageType</key>
    <string>APPL</string>
    <key>CFBundleExecutable</key>
    <string>xulrunner</string>
    <key>CFBundleName</key>
    <string>conkeror</string>
    <key>CFBundleVersion</key>
    <string>93</string>
    <key>NSHumanReadableCopyright</key>
    <string>(c) 2007, Shawn Betts</string>
    <key>NSAppleScriptEnabled</key>
    <true/>
    <key>CFBundleDisplayName</key>
    <string>Conkeror</string>
    <key>CFBundleShortVersionString</key>
    <string>0.9.3</string>
    <key>CFBundleGetInfoString</key>
    <string>Conkeror 0.9.3, A 100% keyboard driven mozilla based web browser.</string>
</dict>
</plist>
2

Select Conkerer as your default through Safari's preferences.

Update per the comment: From their website: "Unfortunately, at this time, there doesn't seem to be a way on OSX to configure conkeror as your default browser. " I just happened to stumble across that. I had never heard of Conkerer until now.

  • Sorry, was meant to say "... with Safari ..." instead of "... with Opera ...". Edited above, thanks anyway. – Nils Wloka Oct 15 '10 at 13:34
  • I gotta say I’ve never heard of that thing before. I thought you meant Konqueror from KDE, but then I saw it has nothing to do with it. – Martin Marconcini Oct 15 '10 at 15:29
0

springify, it's not possible to set conkeror as the default browser on OS X.

0

Have you checked out Default App? It's a preference pane you can install to set any app as a default for a number of different tasks.

It's running on my Macbook running 10.6, and let's me choose any app I want for browsers; I don't have Conkerer but I can only assume it'd work for that too. Worth a download anyway.

Hope this helps.

0

So under the hood, Workgroup Manager creates a plist located at...

~/Library/Preferences/com.apple.internet.plist

Which contains this information...

<?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>mcx_defaultWebBrowser</key> <string>/Applications/Google Chrome.app</string> </dict> </plist>

So create that file and change "/Applications/Google Chrome.app" to whatever the path of your application is. Hopefully that will fix your issue.

0

Here, try Choosy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .