1

Background:

System: macOS 10.13.3 late 2009 iMac

I was originally creating a 25 GB partition for a linux installation, but then something went wrong with it and somehow the 25 GB went to my Recovery HD. I resized it and reclaimed the disk space and tried the partition again. It worked, but now I think the Recovery HD is broken in a way. However, my main OS still works just fine. Here's what comes up in the terminal from diskutil

/dev/disk0 (internal, physical):
#:                      TYPE NAME                 SIZE       IDENTIFIER
0:      GUID_partition_scheme                      *500.1 GB   disk0
1:                        EFI EFI                   209.7 MB   disk0s1
2:                  Apple_HFS Macintosh HD          474.2 GB   disk0s2
3:                 Apple_Boot                       650.0 MB   disk0s3
4:                  Apple_HFS Recovery HD           650.0 MB   disk0s4
5:           Linux Filesystem                       24.2 GB    disk0s5

I'm pretty sure Recovery HD is supposed to be on disk0s3 with Apple_Boot type, but it's not. When I look in Disk Utility and System Information, it shows that Recovery HD is mounted, when it's never shown it before

Question:

How can I solve this, if it is an issue I should worry about? I heard deleting Recovery HD then updating macOS should sort it out, but I have no idea how to do that (I haven't updated to macOS 10.13.4 yet). Otherwise, what can I do with diskutil to resolve this?

Update: Tried updating macOS without removing it, it seems to be related to my issue as it fails to update every time. It just boots back to my login screen saying "Some updates could not be installed automatically"

  • If recovery and/or Hard Drive are broken, on a Macintosh you can always resort to Internet Recovery, which you can start from CMD+R+ALT (option) on boot – Manchineel Mar 30 '18 at 8:35
  • The main hard drive isn't broken, I just can't update or use the recovery partition. I deleted the partitions, and I'm reinstalling macOS from the app store, see if it'll resolve my situation – chaNcharge Mar 30 '18 at 23:54
0

Reinstalling macOS from the App Store seems to resolve this problem; it re-adding the Recovery HD partition correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .