4

I have a MacBook Pro from 2016 and as of this morning I have not been able to save my Word documents (Word 2017). I've never had issues before.

When I press save on a new document, a message pops up saying, "Word cannot save this document due to naming or permissions error on the destination volume." Once I press OK to dismiss the message another message pops up and says the "Document 13" cannot be saved as "New Name". Why is this happening?

1
  • Where are you saving it on? Did you try a different name, a different location, a different disk/USB stick?
    – nohillside
    Mar 28, 2018 at 13:18

10 Answers 10

7

The hint here is "... naming or permissions error on the destination volume." Word is telling you that it sees corruption/damage where you want to save the document.

And I'll bet you see it even if you try to save it to a USB key as well.

Microsoft is a great provider for those of us who do tech support for a living. What that error likely means is that something in MS Word (and possibly the rest of MS Office) on your system is damaged. The part is most likely in the part of Word that writes to disk.

What I would do is run the MS Word/Office installer and reinstall (or repair if that option is available) MS Word.

Failing that it could be that the temporary (recovery) file that Word creates for every document is damaged or that the preference file for MS Word is also damaged. The former is here:

 /Users/<username>/Library/Containers/com.microsoft.Word/Data/Library/Preferences/AutoRecovery.

The latter is here:

~/Library/Preferences/com.microsoft.Word.plist

Trash all the autorecovery files and trash the .plist file and launch MS Word again. That should fix it.

If not you may actually have file system damage on your HD. In that case boot into Recovery Mode, launch Disk Utility and repair/verify the disk.

2
  • Just wanted to comment that reinstalling office and removing an autosave file fixed the issue for me
    – pusle
    Sep 16, 2019 at 9:47
  • Thanks Steve, you just saved me about an hour's worth of work! Nov 8, 2019 at 17:21
1

In case the destination volume where you tried to save the file is a network volume, then go to (Apple) | System Settings... | Privacy and Security | Files and Folders and check there if the application Microsoft Word has "Network Volumes" permissions disabled. If so, flick the switch to enable them. (Alternatively, you can also reset these TCC permissions from the command line via tccutil.)

0

This is a repeating error that seems to keep coming back once you get it. You can re-install Office and it will go away for a short while, then come back. I've seen people buy a new Mac, and the problem will follow from old Mac to new. It is clearly a software problem, and it is somewhere in Word. I've spent hours reinstalling over and over, deleting every last trace if anything microsoft related. It keeps coming back. I don't know if it's random, or a conflict with some other software. But unfortunately, you may be stuck with this problem.

0

The true problem is that word for mac (and Windows) saves in the .docx file format and word can no longer find that folder.For some reason Apple iCloud has taken the folder so that it can not be seen by word.Go to Finder and locate and then drag the 'documents" folder back up to the top of the list of finder folders.That should do it.It did for me.

0

I gave up and clicked the red "Close" button, which allowed the "Save As" box to finally appear. But don't want to live with Word like this going forward - what happened to the usual "Save" and "Save As" drop-downs?

1
  • 1
    you may need to hold down the option key to see save as. Preview and several other mac apps require this now.. just a guess.
    – Natsfan
    Sep 4, 2018 at 18:02
0

Check the permission of the location you are trying to save at. Make sure that 'everyone' is allowed to read and write. That fixed it for me when trying to save to desktop (permissions must have somehow changed).

0

All I needed to do is sign back into MS Office. Worked seamlessly.

1
  • 3
    Did you get the permissions error on saving like the OP reports? Of course if you don’t pay for office that feature won’t work - but I would expect a different alert. If you don’t have the symptom above, deleting this answer and posting it on the correct question for that problem would be best. You could even link that other question here so people can find the two situations if they aren’t sure which they face.
    – bmike
    Oct 29, 2019 at 16:26
0

Okay, I had this problem too and think I found a solution. My circa 2014 desktop runs 10.13.6 and would get locked up on the swirling rainbow ball when I tried to save a Word .doc intermittently. I tried the solutions above and none fixed it permanently, but I finally noticed at the bottom left of the document frame a reference to it seeking my printer.

Why does it seek my printer when I'm not printing and only saving? No earthly idea. But after the umpteenth angry Force Quit, I went to my Systems folder, clicked on the Printer icon, and found that I had none. I refreshed and suddenly both were there (I have a scanner attached as well).

Now, I check that before I open Word, and yep, problem solved. It's stupid and I hate it, but it seems to work now. Hope that helps someone.

0
-1

Alternatively you can mail it to yourself if the problem persists.

3
  • 1
    How do you mail an unsaved document?
    – Tetsujin
    Mar 22, 2020 at 12:24
  • Can you please explain how this can be done in Word on Mac?
    – nohillside
    Mar 22, 2020 at 13:23
  • @Tetsujin In version 16 the email functionality is within the Sharing menu at top right. This works for unsaved documents as well.
    – nohillside
    Mar 22, 2020 at 13:27
-2

I was getting to the point where I couldn't save a Word document even with a new file name, and at times couldn't even open a previous document. I even changed every permission I could think of.

Finally found the answer on a YouTube video (https://www.youtube.com/watch?v=nUlEOoDd7Ks).

I am running Mojave 10.14.6 on a Mac Pro.

Here's what you need to do:

  1. Restart your computer, and as soon as you hear the chime (crescendo), press the Command+R and it will open your Mac in Recovery Mode.

  2. Once your computer opens in Recovery Mode, go up to the "Utilities" in the top menu bar. Scroll down to Terminal...click on it to activate the Terminal

  3. Once the Terminal screen opens (it looks a bit like code...which it is) simply type in the following (there's a grayed out box...just start typing...don't use your cursor):

Type the following: csrutil disable

(That is a space in-between the two command words) Then hit return. You should get a message that it changed the code:

Successfully disabled System Integrity Protection. Please restart the machine for the changes to take effect

  1. Delete the Terminal box using the red button on the upper left corner of the Terminal screen

  2. Under the Apple, go to "restart" and let your computer restart. It worked great on mine...no more permissions issues with Microsoft Word.

2
  • This "solution" is kind of like answering an "I need more fresh air in my house" question with, well just leave the doors and windows open at all times, even when you are away. Doing this leaves your system open to issues with accidental deletion of the wrong files and general malware problems. I wouldn't do this if my life depended on it. Aug 20, 2020 at 20:03
  • 1
    While this might work, I would strongly recommend against anyone following this advice unless you know exactly the repurcussions of disabling your protection.
    – fsb
    Aug 20, 2020 at 21:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .