0

Upgraded on 2018/03/28

After restart macOS, Safari/Google Chrome cannot play embedded videos.

But...

In macOS I opened Finder and located a mp4 file, press space to quick view the content. I got a blank window with a loading icon. (This video can be played in this way yesterday.)

I use ctrl+click and select Open with, use QuickTime to play it. But QuickTime responded an error said The document "xxxx" could not be opened. An unknown error occurred (-101).


Original question

Safari/Google Chrome cannot play embedded videos in website. I can see the 1st frame of the video and I can drag the progress bar to move the timeframe, it shows the frames. But when I clicked play button the video does not get played.

In Google Chrome I have tried:

  • Disabling the hardware acceleration.
  • Disabling the Ad Blocker.
  • Clearing the browser data.
  • Disabling the QUIC protocol.

In Safari I have tried:

  • Allowed auto play for videos with sounds

The websites in question are not using Flash, just HTML5 video.

I am running macOS High Sierra 10.13.3 with Google Chrome 66.0.3359.45 (beta-64bit) and Safari 11.0.3.

0

After contacted Apple Support I got this problem resolved, by using the following steps.

  1. Shut down Mac
  2. Unplug all external devices. To me they are bluetooth keyboard and trackpad
  3. Start Mac and hold on Command + Option + P + R immediately
  4. Mac tried to restart (the screen turned on and off)
  5. Release Command + Option + P + R, let Mac restarted

"Command + Option + P + R" cleared PRAM and let Mac re-exam all hardwares and build correct info into PRAM.

For more information about it please refer https://discussions.apple.com/thread/1788029

0

I experienced the same issue, and it turned out that it was a hardware problem for me: after replacing the hard disk in a Mac mini, I accidentally did not reconnect the audio board. Reconnecting it resolved the problem. A give-away was that the Mac could not detect a sound output either.

So it seems that the -101 error indicates a hardware error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .