1

On an internal data-only SATA HD, the OS forces me to delete files immediately, just as for removable media, a mounted network volume, or any unwritable volume.

Already tried removing and recreating the .Trashes directory, etc.

The error message is familiar:

Are you sure you want to delete “filename.ext”? This item will be deleted immediately. You can’t undo this action.

I am working in the 501 account, the primary admin.

From the volume root, the permissions settings I see are:

drwxrwxrwx root admin .Trashes

And for the Trash subdirectory belonging to the user account, it's also:

drwxrwxrwx root admin 501

Writes are not getting denied by extended permissions (because there aren't any).

The drive is seen by the System as a generic internal journaled SATA HD that's writable, repairable, not ejectable, and not bootable. No problems found with file structures on the volume. Already recreated the Finder's plist file for luck.

I can live with the behavior, but it interferes with file de-duplication apps among other things. What am I not thinking of?

Trash on the System disk works as expected. OS X El Capitan v. 10.11.6 (desktop OS, no OS X server).


Thanks for the pointer to https://apple.stackexchange.com/questions/249328/trash-folder-not-a-directory-files-only-delete-immediately but I've got a different situation.

The earlier question was about a .Trash folder inside the users' Home directory on a startup volume. Other local volumes have a different file architecture, and the OS manages them differently by design.

The answers don't apply either, because the OP's temporary fix does not make a difference for me, and in my case the required attributes for the .Trashes and 501 directories are not getting removed. Those look fine on inspection, although the Trash folder on that volume doesn't function.

  • Make a backup of any data you care about on that drive before doing anything else. This could be “impending doom” or “imminent failure” type situation and it will free you to wipe the drive if this annoyance continues. – bmike Mar 28 '18 at 1:17
  • 1
    Possible duplicate of Trash folder not a directory, files only delete immediately – IconDaemon Mar 28 '18 at 1:19
  • Although the symptoms are similar, a look at their attribute keys shows that in my case, the wonky Trash folders actually are folders with proper permissions. – celeriac Mar 28 '18 at 5:14
1

Filesystem errors that bedevil daily use... grrr... I had something similar to that and nothing I did: repairing the disk, using DiskWarrior and some of the tricks you tried, did a thing.

Finally I got fed up and backed up the drive, deleted the partition and recreated it and reformatted it. Problem went away. If you asked me what caused it I couldn't tell you, but backing up a drive that was basically an internal backup drive so I could re-partiton was almost as annoying as living with the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .