1

I was able to install Windows 7 32-bit on my Macbook 2,1 and it functioned well. Not longer than a week later, Windows Boot Manager hanged, it was stuck on countdown and I couldn't select any other option, using the arrow keys didn't do anything, so I couldn't boot in safe mode, if somehow I was able to select an option (it would give me 1-2 seconds before it hangs), I would be greeted with a black screen and that's it.

I decided to just delete the Windows partition and install it again but it didn't appear to have solved the problem, the installation would also hang 1-2 seconds after the blinking underscore, the same that happened before I deleted the original Windows partition.

I noticed that if I wait a little longer, the progress bar for "Windows is loading files" is actually progressing, albeit at a very slow pace. When it finished, it would give me the Starting Windows screen, but no logo.

Again, I waited longer and then I saw the actual Windows installation, no longer hanging, I could move the cursor and install Windows 7. However, right after the first reboot and I would be greeted again by the Starting Windows screen, it no longer progresses, tried waiting for it overnight and woke up to the same Starting Windows screen.

Please help me, I've tried using a different Windows 7 ISO file and even tried Windows 10, and the same problem persists.

Any help would be very appreciated.

  • Have you installed Windows using Boot Camp? – Nimesh Neema Mar 27 '18 at 13:29
  • @NimeshNeema ergh no, if I did, I'd be seeing an error "No bootable device", I used virtualbox to install windows on a partition, there are a few tutorials out there, no usb nor cd/dvd needed – wasd asdf Mar 27 '18 at 13:37
  • Can you share the link to the tutorial that you followed? Is the Windows installation on a Virtual hard disk?, since you mentioned that you have used VirtualBox to install Windows. – Nimesh Neema Mar 27 '18 at 13:50
  • Appreciate the help @NimeshNeema here: youtube.com/… windows was being installed in a separate partition on my internal drive but i was installing it on OS X through VirtualBox, the tutorial explains it. When I first booted Windows, I was given the "bootmgr is missing" error, I installed paragon and deleted the files inside the ntfs partition and transferred the files from the windows 7 iso to the partition and rebooted again which worked that time. – wasd asdf Mar 27 '18 at 14:00
  • How much RAM is installed? Do you know the speed of the processor? I assume you are installing for a BIOS boot? Have all your attempts been for 32 bit versions? Any 64 bit attempts? Does your DVD drive work? – David Anderson Mar 27 '18 at 14:01
1

Basically, the answer to your question can be found at this link: "Installing Windows 7 or 10 Pro 64 bit without DVD or Flash Drive".

The Boot Camp Support Software (BCSS) for your model Mac is for a 32 bit install of Windows 7. However, I used the same BCSS to successfully install 64 bit Windows 7 and Windows 10 on a 2007 iMac. Since you have 64 bit processors and 4 GB of RAM, you may want to try a 64 bit version of Windows. If you do, then you will want to read this question/answer: "Using Boot Camp Support Software 4.0.4033 to install 64 bit Windows 7 or 8".

Note: Your MacBook2,1 uses the same BCSS regardless of whether you are installing 32 Windows 7, 64 bit Windows 7, 32 bit Windows 10 or 64 bit Windows 10. For a MacBook2,1 the BCSS can be found at "Boot Camp Support Software 4.0.4033".

  • Ever since Windows stopped working, I actually have been using that exact tutorial to attempt installing Windows again on my Macbook, which unfortunately didn't work, but I was optimistic at first. Just now, I tried it with a 64bit ISO of Windows 7 using your tutorial, as expected, it still didn't work and it still hung just like it did for the past attempts. I'm thinking this could be a hardware issue, but I don't really know since OSX is still working fine. I'm guessing if I try to install Linux or any other OS on it, it would just hang the same way. – wasd asdf Mar 31 '18 at 6:31
  • The MacBook2,1 can be either be a late 2006 or mid 2007 model. Can you you select About This Mac from the menu bar and determine which year your model was introduced? This will determine if the Mac has a 32 bit or 64 bit EFI. You will need to know this if you try to install Linux. – David Anderson Mar 31 '18 at 10:00
  • Does your Windows 7 iso contain Service Pack 1 (SP1) or later. This is a requirement according to this Apple website: Install Windows 7 on your Mac using Boot Camp. Also, I assume you checked to see if the Mac's firmware was up to date. What version of OS X are you currently running? – David Anderson Mar 31 '18 at 10:23
  • Appreciate the help btw. Mine's late 2006. I have 10.8.4, installed Mountain Lion using MLPostFactor since Mountain Lion isn't officially supported on my Macbook, I can't seem to install 10.8.5, had to follow a certain tutorial to do so but in the end I got a prohibitory sign on startup so I had to install 10.8.4 again, then again I might've done something wrong so idk. And yes, the iso contains SP1 – wasd asdf Apr 1 '18 at 7:44
  • You have a 32 bit EFI, so if you are going to try to install linux for a EFI boot, you should select a 32 bit version. However, the instructions for installing Ubuntu for a 64 bit BIOS boot are given here. You could try installing Lion so you would not need MLPostFactor. This might make a difference, especially with respect to VirtualBox. – David Anderson Apr 1 '18 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .