6

Every few days or so I keep getting this notification:

enter image description here

I always click on Details but there is no option to stop this from stalking me again.

And I’ve tried System Preferences > Notifications and nothing there stops it, nor does changing the App Store preferences.

Is there a way to stop this? Please tell me there is and how.

7

Yes, this is possible. The safest option is to just move the OSXNotification.bundle file from the /Library/Bundles/ folder. You can do this either by using Terminal or from within the Finder.

Via Terminal

To stop notifications via Terminal, follow these steps:

  1. Launch the Terminal app (by default it's located in the Utilities folder within your Applications folder)
  2. Copy and paste the following command into your Terminal window:

    sudo mv /Library/Bundles/OSXNotification.bundle ~/Documents/

  3. Press Enter

  4. When prompted, enter your password and press Enter again

The above steps are safe. The command at Step 2 simply moves the OSXNotification.bundle file from the the /Library/Bundles/ folder to your Documents folder. This means you can also undo this at any time with these steps:

  1. Launch the Terminal app
  2. Copy and paste the following command into your Terminal window:

    sudo mv ~/Documents/OSXNotification.bundle /Library/Bundles/

  3. Press Enter

  4. When prompted, enter your password and press Enter again

Via the Finder

If you're not comfortable using Terminal, you can do the same thing via the Finder as follows:

  1. Make sure you have the Finder active
  2. Go to the Go menu and select the Go to Folder option
  3. In the field that appears enter the following path: /Library/Bundles/
  4. In the window that appears look for the OSXNotification.bundle file and move it to your Documents folder (or another folder if you prefer)

NOTES:

  • You could also delete the file, but moving it will stop these notifications while giving you the flexibility to activate them again in future should you desire.
  • The above steps will also work for older versions of macOS / OS X. However, the /Library/Bundles/ folder no longer exists from macOS High Sierra and beyond.
4

A blog post titled How-To Disable macOS High Sierra Upgrade Notifications on AppleToolBox outlines the steps to do so:

  1. Click on mac OS High Sierra Notifications Details option OR just open Mac App Store

  2. Choose the Updates Tab from the list of App Store Page options

  3. In the banner for macOS High Sierra, control-click anywhere inside that banner

  4. Select Hide Update and bingo, no more notification!

  • 1
    Nimesh - you should make proper attribution to Appletoolbox.com for the source of your solution. You copy/pasted an image and text verbatim from this site, which is generally an excepted practice on AskDifferent, with attribution. I’ve done it several times in the past myself to avoid pasting a link-only answer. – IconDaemon Mar 27 '18 at 10:07
  • Thank you @IconDaemon for pointing it out. This was my first time. Updated the answer with link to the source. – Nimesh Neema Mar 27 '18 at 10:09
  • You’ve been quite diligent the past few days. Welcome to AskDifferent! – IconDaemon Mar 27 '18 at 10:13
  • Thank you @IconDaemon. I wish to remain consistent and contribute my best. – Nimesh Neema Mar 27 '18 at 10:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .