1

I am running MacOS Server 5.5 on my home Mac (running High Sierra 10.13.4) and wanted to run the VPN service. But when I try to log in from my phone I can't connect. After checking all configurations were correct I decided to take a look at the logs. As you can see below everything goes well until CHAP peer authentication fails.

2018-03-25 16:11:26 CEST    Incoming call... Address given to client = 
192.168.0.248
Sun Mar 25 16:11:26 2018 : Directory Services Authentication plugin 
initialized
Sun Mar 25 16:11:26 2018 : Directory Services Authorization plugin 
initialized
Sun Mar 25 16:11:26 2018 : publish_entry SCDSet() failed: Success!
Sun Mar 25 16:11:26 2018 : publish_entry SCDSet() failed: Success!
Sun Mar 25 16:11:26 2018 : publish_entry SCDSet() failed: Success!
Sun Mar 25 16:11:26 2018 : L2TP incoming call in progress from '[ext ip]'...
Sun Mar 25 16:11:26 2018 : L2TP received SCCRQ
Sun Mar 25 16:11:26 2018 : L2TP sent SCCRP
Sun Mar 25 16:11:27 2018 : L2TP received SCCCN
Sun Mar 25 16:11:27 2018 : L2TP received ICRQ
Sun Mar 25 16:11:27 2018 : L2TP sent ICRP
Sun Mar 25 16:11:27 2018 : L2TP received ICCN
Sun Mar 25 16:11:27 2018 : L2TP connection established.
Sun Mar 25 16:11:27 2018 : using link 0
Sun Mar 25 16:11:27 2018 : Using interface ppp0
Sun Mar 25 16:11:27 2018 : Connect: ppp0 <--> socket[34:18]
Sun Mar 25 16:11:27 2018 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x37649dc1> <pcomp> <accomp>]
Sun Mar 25 16:11:27 2018 : rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x76bbd538> <pcomp> <accomp>]
Sun Mar 25 16:11:27 2018 : lcp_reqci: returning CONFACK.
Sun Mar 25 16:11:27 2018 : sent [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x76bbd538> <pcomp> <accomp>]
Sun Mar 25 16:11:27 2018 : rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x37649dc1> <pcomp> <accomp>]
Sun Mar 25 16:11:27 2018 : sent [LCP EchoReq id=0x0 magic=0x37649dc1]
Sun Mar 25 16:11:27 2018 : sent [CHAP Challenge id=0x2 <5966492a2745621453150b173e631040>, name = "[hostname]"]
Sun Mar 25 16:11:27 2018 : rcvd [LCP EchoReq id=0x0 magic=0x76bbd538]
Sun Mar 25 16:11:27 2018 : sent [LCP EchoRep id=0x0 magic=0x37649dc1]
Sun Mar 25 16:11:27 2018 : rcvd [LCP EchoRep id=0x0 magic=0x76bbd538]
Sun Mar 25 16:11:27 2018 : rcvd [CHAP Response id=0x2 <179b67c31e1454ea110a0ec751fb473b0000000000000000d2e17821ead041c05fbf02dfd6737649adc94491f3b21b9a00>, name = "[user]"]
Sun Mar 25 16:11:27 2018 : sent [CHAP Failure id=0x2 ""]
Sun Mar 25 16:11:27 2018 : CHAP peer authentication failed for [user]
Sun Mar 25 16:11:27 2018 : sent [LCP TermReq id=0x2 "Authentication failed"]
Sun Mar 25 16:11:27 2018 : Connection terminated.
Sun Mar 25 16:11:27 2018 : L2TP disconnecting...
Sun Mar 25 16:11:27 2018 : L2TP sent CDN
Sun Mar 25 16:11:27 2018 : L2TP sent StopCCN
Sun Mar 25 16:11:27 2018 : L2TP disconnected
2018-03-25 16:11:27 CEST       --> Client with address = 192.168.0.24 has hungup

Google doesn't seem to have answers except using Group Manager which is no longer available. A similar question was asked a while ago and the suggested fix was to change MSCHAPv2 to PAP, but the .plist file is now locked so that isn't an option anymore.

If you have any suggestions I'd love to hear them...

EDIT: I have managed to change MSCHAPv2 to PAP. This has not resolved the issue though. I now get the same error but with PAP instead of CHAP

Sun Mar 25 16:47:07 2018 : sent [LCP ConfAck id=0x1 <asyncmap 0x0> 
<magic 0x1e41eb57> <pcomp> <accomp>]
Sun Mar 25 16:47:07 2018 : rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> 
<auth pap> <magic 0x6ef893f8> <pcomp> <accomp>]
Sun Mar 25 16:47:07 2018 : sent [LCP EchoReq id=0x0 magic=0x6ef893f8]
Sun Mar 25 16:47:07 2018 : rcvd [LCP EchoReq id=0x0 magic=0x1e41eb57]
Sun Mar 25 16:47:07 2018 : sent [LCP EchoRep id=0x0 magic=0x6ef893f8]
Sun Mar 25 16:47:07 2018 : rcvd [PAP AuthReq id=0x1 user="Ivar De Boer" 
password=<hidden>]
Sun Mar 25 16:47:07 2018 : sent [PAP AuthNak id=0x1 ""]
Sun Mar 25 16:47:07 2018 : PAP peer authentication failed for Ivar De 
Boer
Sun Mar 25 16:47:07 2018 : sent [LCP TermReq id=0x2 "Authentication 
failed"]
Sun Mar 25 16:47:07 2018 : Connection terminated.
Sun Mar 25 16:47:07 2018 : L2TP disconnecting...
Sun Mar 25 16:47:07 2018 : L2TP sent CDN
Sun Mar 25 16:47:07 2018 : L2TP sent StopCCN
Sun Mar 25 16:47:07 2018 : L2TP disconnected
2018-03-25 16:47:07 CEST       --> Client with address = 192.168.0.246 
has hungup

EDIT 2: As far as I can tell the error with both CHAP and PAP lies in the authentication of username and password. I used the 'configuration profile' option aswell as manual configuration, but get the same failed CHAP every time. I have tried changing passwords and trying all passwords I know I have used with this mac. I assume the correct username and password are the same as the account that has acces to the VPN? If so, those are definitely not working...

You must log in to answer this question.

Browse other questions tagged .