1

I've recently bought an used mac mini (early 2009 version) patched with preinstalled HighSierra on it. My main goal is to get it working. Currently I'm trying to install El Capitan which is somehow not possible (details below).

It came with firmware password so I cleared it with NVRAM hack. Unfortunately it enabled SIP, so USB is not working after OS boot. It's getting voltage but not operating. Then I started to deal with boot options (order as on apple support page):

  1. Safe mode - SIP still enabled -> USB not working
  2. Startup manager - I've created (with transmac, i will try on another mac with createinstallmedia) bootable OS X El Capitan USB (with ignore ownership unchecked) -> prohibited.

I've also switched HDD, it turned out it has WinXP installed -> USB not operating

  1. AHT / Diagnostics not working -> OS booting, no power on USB. Internet AHT -> prohibited.
  2. NetBoot - don't have one -> skipped
  3. Recovery. None of the options working, all result in prohibited sign.
  4. NVRAM / PRAM reset. Yup, I've tried, didn't change anything.
  5. Single-user mode - Freezes on right after [PCI configuration begin]
  6. Target disk mode - not needed now, skipped
  7. Verbose mode - USB not operating, gets to login screen though.

Is anything left I haven't try? Or I would choose having expensive paperweight or letting apple service manage to run this.

  • 1
    SIP shouldn't have any affect on your machine's USB port. It sounds like it just has a bad USB port. Are all 4 or 3 of them not working? – l008com Mar 24 '18 at 0:51
  • 1
    First and foremost, your Mac is not compatible with High Sierra. Whatever hack that was used to install it is most likely causing you issues. Get a copy of El Capitan and install that cleanly so you have a valid starting point – Allan Mar 24 '18 at 3:03
  • @l008com When I boot it shows a window where it's written that enabling SIP can cause USB not working. – Trishun Mar 24 '18 at 4:15
  • @Allan I know it's not compatible. I've written that in pt.2. I try to install El Capitan and somehow it's not possible. – Trishun Mar 24 '18 at 4:16
  • That SIP / USB messages clears up a lot. The USB issue is definitely being caused by the high sierra hack. Like @Allan said, reformatting and starting fresh with 10.11 should solve the problem entirely. – l008com Mar 24 '18 at 4:18
1

Your Mac is too old to support Internet Recovery. So it seems like you have three options:

A) You can dig the InstallESD.dmg out of the El Capitan installer app (see below), and burn that to a DVD, then boot off that DVD to wipe the hard drive and reinstall the OS.

or

B) Get another older Mac that is running 10.7 thru 10.11. Boot yours with the T button held down, into Target Disk mode. Plug it in to the other Mac via Firewire. You can erase the drive from the other Mac, and then install El Capitan from there. Run the installer on the other Mac, and when you get to the screen where you choose the disk, just choose the disk of your Mac mini. Only Macs running 10.11 or older will let you run the 10.11 installer.

or

C) If you can'd do either of these, you could do a bit of a hybrid of the two. If you have access to another Mac that is newer, and you have a Thunderbolt to Firewire adapter, you can still boot the mini into Target Disk mode. Then from the newer Mac, erase the hard drive. Then partition the drive into one small 10 GB partition, and one bigger partition. Get the El Capitan installer, extract the InstallerESD.dmg image out of it, and 'Restore' it using Disk Utility, to the 10 GB partition. You can then reboot the mini off of that partition, and install the OS on the bigger partition. Once that is done and you're running off the new OS, you can go into Disk Utility and delete the smaller partition.

Option 3 is a bit more complicated but it should work. If you don't have access to ANY other Macs, or any install DVDs, then you might be out of luck until you can get access.

To get the InstallerESD.dmg disk image out of the El Capitan installer: - Right click on the Install OS X El Capitan.app and choose "Show Package Contents" - From there, navigate to Contents/SharedSupport/InstallESD.dmg - Just drag that disk image to your desktop and work with it from there.

  • Thank you. Unfortunately I only have macs with 10.3 or 10.13, to option B is "slightly" inaccessible. I've burned InstalESD to DVD, it's not showing as bootable. I've managed to get DVD image of ElCap installation disk, I will buy more dicsc and burn it. – Trishun Mar 25 '18 at 18:26
  • Perhaps you burned it wrong? You need to mount the image and burn that volume to the DVD, so you have a disk filled with all those files, not a disk that simply contains InstallerESD.dmg. – l008com Mar 25 '18 at 23:23
  • I've mounted and burned it in PowerISO. – Trishun Mar 26 '18 at 21:13
  • I've never heard of that, why not just use Disk Utility? – l008com Mar 27 '18 at 3:20
  • Because currently I only have working machines with Windows and Ubuntu. I would do this on my mini if USBs have worked... – Trishun Mar 27 '18 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .