0

I have a mid-2012 MacBook Pro Retina, and recently replaced the SSD (Samsung 860 EVO 1TB) and logic board (refurb).

The original machine was crashing, and long story short diagnostic mode indicated an unfixable hard drive error. I first upgraded the SSD, OS install went smoothly and the machine worked well for a few days, but soon started having the same random crashing issues. The problem seemed to be with the logic board, so I replaced that as well.

With the new logic board in place, installing Mac OS High Sierra from USB seems to go fine at first, until it is time to boot. The SSD is recognized by the installer, and the first step of OS installation takes all of 3 minutes. On trying to reboot, though, it boots from the USB instead of the SSD. When removing the USB and rebooting, I get the flashing question mark folder of death.

When inspecting with Disk Utility (disk info), the new SSD, 'Container disk1', and the install partition are all flagged as not bootable.

I tried booting from USB and went to Startup Disk, hoping to select the SSD. No luck, it didn't appear there.

I have tried reformatting the SSD and reinstalling the OS a couple of times, but no change. I'm using the default settings (APFS format, GUID scheme) when formatting the SSD.

I am trying to find out if there is a way to make the SSD bootable from the command line.

Some digging led to the bless command, which seems to serve this purpose. I tried a few variants

  • bless --setBoot --device /dev/disk1s1

    • Could not access boot.efi file at /var/tmp/RecoveryTempbless.PQpy/<<<SN>>>/Library/CoreServices/boot.efi

    • Couldn’t set bless data in preboot volume for device /dev/disk1s1

  • bless —setBoot —mount /Volumes/dotty
    • Can’t load /Volumes/dotty//usr/standalone/i386/apfs.efi
    • Could not load apfs.efi data from /Volumes/dotty//usr/standalone/i386/apfs.efi

With no luck. Googling these errors doesn't seem to turn up anything but the original source files so I'm pretty sure I'm barking up the wrong tree.

Looking in /Volumes/dotty (my install partition) showed a pretty sparse file system, with one main directory (macOS install data or similar). Using bless and trying to specify the apfs.efi file that is buried in the install files is of no avail; I get similar errors to those above that I won't type out here.

It looks like the install may have frozen for some reason. What else can I try?

2

It seems to work now after one more tweak; I posted the question because I hope it's of use to some other lost soul.

I tried erasing the SSD once more with Disk Utility. This time I did two things differently: 1) I used the default name 'Untitled' for the disk, and 2) I used the default 'Mac OS Extended' option for the file system instead of APFS when erasing the disk. This time the OS install proceeded successfully past the first reboot.

Thing #2 is probably what matters, but it's unclear why. It is also possible that some of the dinking around with bless had something to do with the success this time, but I doubt it.

  • APFS has been nothing but problems, i can't believe they just abruptly switched to it half-assedly instead of doing a slow, tiered introduction. – l008com Mar 24 '18 at 0:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .