6

I have an iPad, an old iPhone 3GS and a new iPhone 4S. When someone sends an iMessage to me it appears simultaneously to both my 2 iPhones but does not appear on the iPad. When I respond from the iPad the message appears on the iPhones.

A friend has a worse problem where his new iPhone 4S does not receive any iMessages, instead the are only received by his old 3GS.

Is there a trick to setting this up? I have tried making sure that all the "Receive At" email addresses are synchronized on all devices. Could this be a bug in iOS 5.0.1?

  • Are all your devices signed in to the same Apple ID? – Global nomad Nov 23 '11 at 6:28
4

It's less a bug than getting the people to send you an iMessage to your email and not your phone number.

The database actually has two accounts for you and since they are not merged / unified on the server end, you will end up with two accounts / two endpoints and messages to one are not combined with messages to the other.

iMessage in iOS6 does a much better job of unifying several emails and phone numbers, but in 5.0.1 there is no unity. I still like to have one address for my "caller ID" so that contacts tend to reply to my preferred account.

0

You have to turn on the same phone number and email accounts in iMessages on all devices to send as... and received from... all these phone number and email accounts to make it work.

If you forgot to turn on send as your phone number or any of your email, then it won't receive from them.

Go to: iMessages > Settings > Send & Receive > turn on all your phone numbers and email.

Most importantly, set "Start new conversations from" your phone number, not from your email addresses.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .