2

I am trying to convert a iso file to img file using the hdiutil command in the cli terminal but it seems my hdiutil won't recognize the iso.

hdiutil convert /mypathdir/ubuntu-16.04.4-desktop-amd64.iso" -format UDRW -o "/mypathdir/ubuntu-16.04.4-desktop-amd64.img
hdiutil: convert failed - non riconosciuto

(non riconosciuto = not recognized )

My machine is running OS X 10.7 Lion. The iso comes from the Ubuntu site so it's ok. I've also tried with a early version of Ubuntu but i've got the same results.

I've tried the verbose mode of the command and this is its output:

mymachine$ hdiutil convert ubuntu-16.04.4-desktop-amd64.iso  -format UDRW -o ubuntu-16.04.4-desktop-amd64.img -verbose
hdiutil: convert: processing "ubuntu-16.04.4-desktop-amd64.iso"
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score      100, CCarbonBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  6, score    -1000, CVectoredBackingStore
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CMacBinaryEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CAppleSingleEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CEncryptedEncoding
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CUDIFEncoding
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CSegmentedNDIFEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CSegmentedUDIFEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CSegmentedUDIFRawEncoding
DIDiskImageInstantiatorProbe: interface  0, score    -1000, CUDIFDiskImage
DIDiskImageInstantiatorProbe: interface  1, score        0, CSparseBundleDiskImage
DIDiskImageInstantiatorProbe: interface  2, score        0, CSparseDiskImage
CRawDiskImage: data fork length 0x000000001D987C64 (496532580) not a multiple of 512.
DIDiskImageInstantiatorProbe: interface  3, score     -100, CRawDiskImage
DIDiskImageInstantiatorProbe: interface  4, score        0, CDARTDiskImage
DIDiskImageInstantiatorProbe: interface  5, score        0, CDiskCopy42DiskImage
DIDiskImageInstantiatorProbe: interface  6, score        0, CNDIFDiskImage
DIDiskImageInstantiatorProbe: interface  8, score     -100, CShadowedDiskImage
DIDiskImageInstantiatorProbe: interface  9, score    -1000, CCFPlugInDiskImage
DIDiskImageInstantiatorProbe: interface 10, score     -100, CWrappedDiskImage
DIDiskImageNewWithBackingStore: probe fails to find appropriate CDiskImage class.
convert: unable to recognize "ubuntu-16.04.4-desktop-amd64.iso":
non riconosciuto.hdiutil: convert: result: 109
hdiutil: convert failed - non riconosciuto

It seems there is a problem with some libraries, perhaps a bad installation of hdiutil. I have the same results if I try to use disk utiliy program.

What can I do to solve the problem with my machine and convert the iso to img?

  • Why do you want to convert iso to img? – pixelomer Mar 23 '18 at 12:25
  • 1
    It may be that the "disk format" of the ISO is a file system that the Mac does not know about like ext. Also an ISO will open in Finder without converting to a DMG. But, again, if it is a foreign files system you still won't be able to read from it. – Steve Chambers Mar 23 '18 at 13:42
  • @SteveChambers : Your comment put me on the right way. Searching deeply I've read this link : askubuntu.com/questions/468437/… where I've got that my mac needs a 32bit efi. So I've downloaded a 32 bit iso of ubuntu ubuntu-14.04.5-desktop-i386.iso and it's been recognized from hdiutil. – Sauro Mar 25 '18 at 15:13

You must log in to answer this question.

Browse other questions tagged .