1

I have a MacBook Pro and a MacBook Air, as well as an iPhone SE. I use iCloud to synch Safari bookmarks. Both computers run macOS 10.12.6 and Safari 11.0.3; the iPhone runs iOS 11.2.6. All this software is up-to-date. Synching has worked quickly and correctly for many months. Synching contacts and Keychain and Find My Mac continue to work correctly.

Yesterday, bookmark order and organization became random.

I tried to flush the Bookmarks data in iCloud by manually erasing the bookmarks on both computers, until both Bookmark lists were empty, then re-adding them (with a Bookmarks.plist file from my Time Machine backup) to one computer. They display correctly on whichever Mac I use...but when the second computer (previously empty) synchs to iCloud, Bookmark order on both computers is quickly randomized.

Multiple times, I've enabled and dis-enabled Safari in iCloud Preferences on both Macs, and enabled and dis-enabled iCloud itself on all three machines. I've reloaded new macOSs (from Recovery) on both Macs. I've hard-restarted the iPhone. The Bookmarks continue to scramble when a second computer is connected.

There are several hundred bookmarks, and many folders, and I don't relish sorting them manually. Is there any other tactic I might employ to maintain the sort order which appears when the archived Bookmarks.plist is first opened?

1

This sounds like a Safari issue, not an iCloud or Bookmarks issue, to verify that, lets reset Safari back to scratch. This wont delete any bookmarks. You may want to clear the history too.

How to fully reset Safari on your Mac

Remove Safari’s configuration folder:

  1. Open the Go menu in the OS X Finder
  2. Hold the Option key and choose the Library option that appears
  3. Move the “Safari” folder in here to your desktop

Remove Safari’s window state:

  1. Open the Library > Saved Application State folder
  2. Locate the “com.apple.Safari.savedState” folder
  3. Move this folder to the trash

Remove Safari’s application caches:

  1. Open the Library > Caches folder
  2. Locate all folders that begin with “com.apple.Safari”
  3. Move these folders to the trash.

Remove Safari Cookies configurations:

  1. Open the Library > Cookies folder
  2. Remove the file called “com.apple.Safari.SafeBrowsing.binarycookies”

Remove Safari’s preferences:

  1. Open the Library > Preferences folder
  2. Remove any file that begins with “com.apple.Safari”

Remove user plug-ins:

  1. Go to the Library > Internet Plug-Ins folder
  2. Move all items from this folder to your Desktop (or elsewhere)

Remove global plug-ins:

  1. Go to the Macintosh HD > Library > Internet plug-ins folder
  2. Move all items out of this folder except the following plug-ins:

*

Default Browser.plugin
iPhotoPhotocast.plugin
Quartz Composer.webplugin
QuickTime Plugin.plugin

*

That may help with the issue you are having via Safari and not your bookmarks.

  • 1
    Hello Melvin, thanks for your comprehensive suggestion. I took each of these steps on both Macs this morning. The only oddities were that neither machine had a ~/Library/com.apple.Safari.savedState folder, nor a Macintosh HD > Library > Internet Plug-ins Default Browser.plugin. (A Finder search didn't reveal them, either.) I took all the other steps, and retrieved from TM a Bookmarks.plist from several weeks ago, before this issue arose. Adding that .plist on the Pro enabled the Bookmarks to display correctly. However, when I enabled iCloud > Safari, they – David Mar 23 '18 at 16:30
  • 1
    ...on the Pro, the Bookmarks scrambled almost immediately. The Air remained offline. Sigh. – David Mar 23 '18 at 16:38
  • Contact Apple Support, have them check and see if it's an issue with the cloud, just let them know that you troubleshooted Safari already. It's fine if you don't have certain folders or items, not all Macs will. – Melvin Jefferson Mar 23 '18 at 17:02
0

I spent more than an hour on the phone with Apple Tech Support this afternoon. The tech said he saw nothing awry in iCloud's status. We traipsed over the same ground I described in my original post, and the bookmarks continued to spontaneously randomize. Finally, he suggested disconnecting both Macs and the iPhone from iCloud, clearing all bookmarks, and importing the backup Bookmarks.plist file into Safari yet again. After then seeing the Bookmarks in correct order in Safari on the MacBook Pro, we exported the Bookmarks (File > Export Bookmarks) as an .html file.

With both Macs and the iPhone cleared of all the bookmarks, and still disconnected from iCloud, the .html file Bookmarks were then imported back into Safari on the MacBook Pro. The bookmarks appeared in Safari, in proper order (although one level down within an "Imported 3-23-18" folder - that was going to be easy to fix). iCloud synching of Safari was then re-enabled, and the Bookmarks propagated, remaining in correct order.

Perhaps the Bookmarks.plist file, backed up from one computer, had some oddity that tripped iCloud, or the other computer. In any event, adding the export/import in .html step apparently made the difference. The Bookmarks are now in correct order, and remain so.

-1

Give iCloudKit time. It’s Apple’s issue.

  • This is not a very good answer. See How to Answer for more info. – fsb Dec 20 '18 at 14:48
  • Unfortunately I cannot provide any links from Apple regarding this issue. All I wrote is from my own (and other users ) experience. So I couldn’t be more analytical. – user312912 Dec 21 '18 at 6:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .