0

I have a 'slight' issue with my macbook and was wondering if anyone could help me please.

Model: A1278 (EMC 2419*) MacBook Pro "Core i5" 2.3 13" Early 2011 OS: Yosemite

The machine one day abruptly switched off while in use. The power button is ineffective and gives no response. To power the machine up, I removed the battery and attached the power cable.

With the cable attached, the machine turns on. I have password protected the hdd, so the first thing it reaches is a pre-boot user selection. It allows me to use the trackpad and keyboard to enter this information.

From here, the machine begins to boot. It displays the apple logo and progress bar but abruptly shuts off around half way through the boot sequence. Once it has shut off, the power button is once again ineffective. To restart I have to remove and reattach the power cable.

Resets: I have tried resetting the smc, pram, nvram to no avail.

I have run an extended diagnostic hardware test which found no problems

Recovery: I do not have a recovery partition. I have tried internet recovery. I can enter the wifi details and it downloads the software I assume. Once it begins to boot, it shuts off before it gets to the recovery menu.

I have also tried recovering from a USB, the machine shuts off before the menu.

HDD: I have removed the hard drive and have attached it to my iMac via USB > SATA, I have found no issues there and can access the data.

Does anybody have any suggestions?

Thanks in advance.

  • 3
    Sorry to say but it sounds like you have a bad logic board. – l008com Mar 22 '18 at 9:30
  • I was hoping that wasn't the case, but it seems right. Thanks. – Drew Mar 22 '18 at 9:33
  • Can you boot from the hard disk while attached to your MBP via USB rather than internal? – FiddleDeDee Mar 22 '18 at 9:33
  • Have you tried a different power adapter, connected to a different plug in your house? Worth a shot just for the sake of completeness. – l008com Mar 22 '18 at 9:34
  • – Ian, I'm not sure I follow. Do you mean, can I boot via USB? – Drew Mar 22 '18 at 9:37
1

The problem was the keyboard.

I detached all of the internal cables. The keyboard, the trackpad, the keyboard backlights, the optical drive, bluetooth and hard drive.

I attached the HDD and a Keyboard via usb and started the machine by attaching the power cable. From there, success, it booted to desktop.

I then started to reattach all until I found the culprit. Macbook now working minus the internal keyboard.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .