0

I'm trying to save a website as a PDF file using the File -> Print.... The PDF preview has a white border all around, as does the final final PDF product. I've followed the steps suggested on this website, but that doesn't work. Other websites suggest using File -> Page Setup, but that option no longer exists in later versions of macOS. How can I force the PDF file not to have any white borders?

For what it's worth, I'm using Safari 11.0.3 on macOS 10.13.3.

Thanks in advance.

2

It sounds like the border is a part of the PDF document itself, in which case it's not an issue with printing preferences. The easiest solution is to crop the PDF in Preview, then print it.

Instead of File > Print, perform File > Export as PDF (or Save as).

Open the PDF in Preview and crop it.

From the above Apple support article:

If the Markup toolbar isn’t showing, click the Show Markup Toolbar button , then click the Rectangular Selection button .

Select the portion of the page you want to keep.

Click the Crop button in the Markup toolbar (or use the Touch Bar).

Once you select the portion, you can alternatively the shortcut command + K to crop it as well.

Once you are finished, save the PDF if you wish and print it.

  • Thank you! This was driving me nuts. Exporting as PDF works rather nicely. – Rain Mar 21 '18 at 4:35
  • What should I do on Chrome? That doesn't have an exporting option... – Rain Apr 26 '18 at 2:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .