I use Macbook Air and Lion. I use Time Machine to back up on my Drobo FS. All seems to be ok until I use Parallels. The Time Machine seems to take my virtual machine as one file so every time I open it Time machine wants to back up the WHOLE virtual machine although I maybe have changed only a word in a file. This leads to huge back ups of 20-30 G. Is there anything I can do about this unnecessary backup? Or is there any way I can tell the Time Machine not to back up my Windows files? Can I use tmutil and in that case how?



Parallels have instructions here for making their software (version 6 or later) work better with Time Machine. You can either optimise your VMs for Time Machine backup, or disable backup for them.

Parallels Desktop for Mac includes improved integration with Time Machine. When backing up the virtual machine, it will only backup the recent changes (the latest snapshot), but not the whole virtual hard drive. Thus, the backup process will take less time and use less space on your Time Machine storage device.

To enable improved integration with Time Machine, please go to Virtual Machine Configuration, choose Options and hit Backup.

Select "Optimize for Time Machine" in SmartGuard menu.

If you do not want your virtual machine to be backed up by Time Machine, you need go to Virtual Machine Configuration --> Options --> Backup and put a checkmark on “Do not back up with Time Machine”.

In Parallels 7 the control panel looks like this:

enter image description here

Note that when you enable this feature, it will take up more space on the disk. Also, Auto Compress will be disabled.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .