4

The set-up that has worked for me for years and years on end suddenly – as of this morning – failed to work.

I have my Mac switched on most the time, and to connect to my iPad I set up a network for Wifi: Create Network > Channel 11 > Security 128-Bit WEP. On my iPad, I could select it, enter my password, and enjoy all the couch-based browsing I wanted. Nothing router or modem based, as far as I am aware.

It worked all fine and dandy until yesterday.

This morning it decided not to:

Wi-Fi has the self-assigned IP address 169.XXX.XXX.XXX and will not be able to connect to the Internet.

(As I found, the 169 here is a dummy IP address that indicates no connection can be made.)

Indeed, if I reconnect my iPad to this network, it warns that "This network is not connected to the Internet" (and "Join anyway" does, as expected, nothing).

I have:

  • restarted my Mac
  • restarted my iPad
  • restarted my modem (although Internet works correctly through the Mac)
  • created a new network
  • created a new network location
  • renewed the DCHP lease
  • deleted files such as com.apple.network.identification.plist, NetworkInterfaces.plist, and preferences.plist, and some more, as per https://www.technobezz.com/fix-common-connection-wifi-issue-self-assigned-ip-macbook/ and similar pages
  • copied the EtherNet IP address to Wi-Fi's TCP/IP, using "DHCP with Manual Address" as per https://discussions.apple.com/thread/5355232
  • deleted the Keychain entry for the password, as per a YouTube movie that "works for some"
  • created a new user (which might have solved it if it's due to local settings).

This seems to cover answers to similar issues such as in Wi-Fi no longer connecting to the internet and MacBook connects to network over Ethernet but not WiFi.

I must admit that I did not follow the suggestion "... or reinstall the OS" under the last one, as it does not sound too appealing. I run a pretty old OS: 10.7.5 – but not by choice. I have some software crucial for work that has been proven incompatible with newer versions of OS X.

I am not aware of any possible modem/router problems I might be having – if so, they appeared overnight. I've never had to configure anything else 'manually' before; default settings always worked.

ifconfig reports the following:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 ::1 prefixlen 128 
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=27<RXCSUM,TXCSUM,VLAN_MTU,TSO4>
    ether 64:b9:e8:bb:06:9a 
    inet6 fe80::66b9:e8ff:febb:69a%en0 prefixlen 64 scopeid 0x4 
    inet 92.108.125.5 netmask 0xffffff00 broadcast 92.108.125.255
    media: autoselect (100baseTX <full-duplex>)
    status: active
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 04:1e:64:f1:24:2d 
    inet6 fe80::61e:64ff:fef1:242d%en1 prefixlen 64 scopeid 0x5 
    inet 10.0.2.1 netmask 0xffffff00 broadcast 10.0.2.255
    inet 169.254.17.180 netmask 0xffff0000 broadcast 169.254.255.255
    media: autoselect
    status: active
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 64:b9:e8:ff:fe:bb:06:9a 
    media: autoselect <full-duplex>
    status: inactive
p2p0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 2304
    ether 06:1e:64:f1:24:2d 
    media: autoselect
    status: inactive
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
    inet 10.10.6.6 --> 10.10.6.5 netmask 0xffffffff 

but reading its man page only makes me realize how little I know of both the software and hardware parts of this (about this much -> ·). I do recognize 92.108.125.5 as my local IP address.

Anything left I can try? I'm slowly leaning towards the theory that although applying a sledgehammer might not fix it, at least it'll get rid of my frustration and give me an excuse to replace everything with new stuff.

  • 1
    Did you just soft-restart the iPad? If so, try a hard-reset: hold down power and home button until the screen goes black, then power up. – IconDaemon Mar 18 '18 at 14:35
  • 1
    @IconDaemon: yeah I did hard-reset it. – usr2564301 Mar 18 '18 at 14:46
  • 1
    It isn't perfectly clear to me (I'm a little dense) are you sharing a wired internet connection from your Mac to your iPad (so like internet->modem->cat5->mac->WiFi->iPad? Can your iPad connect to any other WiFi networks, or is it only this one that is giving it trouble? – dwightk Mar 20 '18 at 19:09
  • 1
    I know it’s not related to the question, but please, please don’t use WEP. – JBis Mar 20 '18 at 19:58
  • 1
    @dwightk: the iPad is working fine, it can connect to other WiFi networks. It's my Mac that refuses to create a connection between WiFi and the Ethernet cable. – usr2564301 Mar 20 '18 at 20:29
4
+100

I think you may be going about this all wrong.

Macs that are running OS X Lion (10.6) or later have a built-in feature called "Internet Sharing" inside of your system preferences.

System Preferences: Internet Sharing

  1. Click on the  icon in the top menu bar and select System Preferences.
  2. Now click on Sharing.
  3. Click on Internet Sharing and then tick the checkmark next to Wi-Fi.
  4. Now turn on Internet Sharing by clicking the tick mark next to Internet Sharing in the sidebar.
  5. Click Start on the menu that pops up in order to turn Internet Sharing on. Your Mac should now show up as a Wi-Fi hotspot for your iPhone, iPad, and similar devices. Simply connect to it like you would any other Wi-Fi network. You can even change the name of your Mac in the same Internet Sharing menu to make it easier to find if you'd like.

via iMore

This should offer you what you are looking for.

  • 1
    I am astonished ... but note it did not work straight away! If you can add some more details, it may help others with a similar problem. (1) The "Computer Name" should have something in it. I tried my old 'network' name and ... that worked! It even required the original password. But ... (2) I can no longer edit or add this under "Network" (where I previously defined it). It has the entry "Internet Sharing: On" and does not allow a change. So the old network/password must come from the earlier definition of a 'manually' created network? – usr2564301 Mar 21 '18 at 23:21
  • 1
    ... What I mean is, would this also have worked without having a previously 'manually' created network? If so, I would guess the connection name would be the "Computer Name" – but with what password? – usr2564301 Mar 21 '18 at 23:23
  • Your original network password. If you can find or remember that, then that should be it. If you can't then you'll need to contact your network provider to get them to show you how to reset it. – Melvin Jefferson Mar 21 '18 at 23:23
  • By default the computer name should have already been identified if you set up the Mac from scratch. But feel free to edit and add-on to my answer. – Melvin Jefferson Mar 21 '18 at 23:27
  • 1
    Melvin, in that case it could very well be the defaults have always been correct before, but I messed them up with my own attempts, which included deleting preferences and setup files. I've added a screenshot of my current settings for posterity. – usr2564301 Mar 21 '18 at 23:43
1

So it sounds like you are trying to create a WiFi hotspot on your Mac so that your iPad can connect to the Internet (getting this clear in my head) through your Mac and then out to your cable modem/DSL/whatever, correct?

What is sounds like (IMHO) is that there may actually be an issue with the WiFi subsystem in the Mac. Hardware or Software, dunno, it could be elsewhere but we need to find where.

What you need is something else as a verification that it is not some strange interaction with your iPad and Mac. So if you have another Mac, iPad or iPhone, Heck even a Windows/Linux laptop with known good wifi that you can test against the Mac. Find a friend with a phone or laptop with wifi and offer them beer.

What you are trying to discover is where the fault lies. Is it the iPad, or the Mac?

You need to determine where the fault lies. Once you have isolated where (EG which device) the problem is you will have removed one of the variables and be able to focus on the problematic device.

===========

An afterthought. Your router doesn't have WiFi? And you are connecting to it with an ethernet cable? I also assume that getting to the internet on the Mac is not an issue?

  • 1
    I strongly believe my Mac setup is the problem – WiFi has the dreaded "self-assigned IP address" (the default 'no connection possible' value) and it refuses to take just about any other value. There are hints here and there that it just may not be able to find a 'free' IP address, but I found no hands-on way to check or correct that. – usr2564301 Mar 21 '18 at 9:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .