2

I've got this problem where I can't alter some pmset values in Terminal. I can change them, the changes are registered with pmset -g, but they are ignored.

Example:

pmset acwake 0

but Mac still wakes if unplugged.

pmset hibernatemode 0

but it still hibernates after a few hours of sleep.

I've reset PRAM and NVRAM. I've switched off SIP. I've moved on to pulling my hair out.

Any advice in terms of solutions or diagnostic options would be greatly appreciated.

Late 2012 13"MBP
2.9 GHz i7
OSX10.13.2
2 TB Crucial SSD
16 Gb RAM
  • ok, if it is a daft question please ignore! - are you making these changes as root? or as an "ordinary" user? – Solar Mike Mar 18 '18 at 7:06
  • It prompts password verification so, yeah. I'm admin. – Eric Cardinale Mar 18 '18 at 11:18
  • Are you using the pmset -a qualifier to change settings for all? NOTE: -b - on battery, -c - on charger, -u - on UPS. -a - all circumstances. – IconDaemon Mar 18 '18 at 14:40
  • Yes, sudo pmset -a hibernatemode 0 – Eric Cardinale Mar 18 '18 at 19:04
  • Stop the PRAM, NVRAM or SMC resets and pulling your hair. These methods are a total waste of time in this case 😎. – dan Aug 13 '18 at 23:18
1

I identified a serious problem between power management and sleep states management in version 10.13.4 of MacOS X (I had regular crashes on sleep and hibernate exit: around 5 times a day, and files modifications lost).

I thoroughly tested 10.3.5 and Apple seems to have fixed many problems. standby 1 isn't anymore causing a crash on encrypted filesystem on hybernate exit and on sleep exit, acwake 0 is working as expected.

But lidwake 0 is still not working, thus potentially causing the MacBook Pro overheating in a bag around the lower part of the screen and the upper part of the keyboard.

The DestroyFVKeyOnStandby 1 isn't yet in the documentation and causes a crash on hibernate exit.

The documentation (man pmset) isn't appropriate for the pmset command:

  • some options aren't documented,
  • others aren't behaving as documented.

pmset -g pslog is pretty useful to understand this behaviour which is changed without notice and without documentation.

I advise you to download MacOS X 10.13.5 combo update

Now I recovered a MacBook Pro I could use to work.

NB: I didn't tested 10.13.0..3 nor 10.13.6 nor 10.14.... (nothing needed, not yet a free dayfull of work to waste on tests, and no time to spend for an editor who doesn't make a correct documentation).

  • Hi, lidwake 0 is still not working in 10.13.6. Have you found the solution or workaround yet? Thanks a lot. – sgon00 Nov 28 '18 at 9:38
  • 1
    pmset lidwake 0 is still failing, didn't find any workaround. The documentation is wrong and hiding functions. Please report these bugs to Apple: bugreport.apple.com . – dan Nov 30 '18 at 7:58
  • 1
    Is the apple bugreport only a private report? Not like other services such as github issues or bugzilla etc.? I was about to find an existing bug and simply upvote it, but it seems that I can not access other people's bug reports... – sgon00 Nov 30 '18 at 8:12
  • 1
    Exactly. My personnal piece of advice is to advertise its record outside of the Apple information black hole for others to be aware that a problem is duly reported since more than 5 years. – dan Nov 30 '18 at 12:27
0

For the record, the partial answer is this... Mountain Lion aggressively hibernates

Which is autopoweroff 0 to stop the hibernating (on my rig anyway) but acwake 0 is stil baffling. It seems to be a bug as others are unable to alter this setting from 1 to 0 as is mentioned in the linked thread.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .