20

When pushing a key for a long time, you expect to print a lot of times the same char. Instead of that, I now have a popup suggesting all accentuated chars.

How to disable that and come back to a classic keybaord function?

3 Answers 3

30

As given in the link by Tom Gewecke, you can disable the Character Picker by typing the following in a terminal :

defaults write -g ApplePressAndHoldEnabled -bool false
18

Open a terminal (e.g. Terminal.app) and write

defaults write -g ApplePressAndHoldEnabled -bool false

then press Enter.

Any open applications will still use the "Press and Hold", but if you quit them and then open them again they should work as expected (use key repeat instead of "Press and Hold").

Reference: http://m10lmac.blogspot.com/2011/07/os-x-107-lion-getting-rid-of-character.html

2
  • 2
    Can you please summarize to help future users even if the link breaks?
    – nohillside
    Commented Nov 22, 2011 at 12:56
  • Any running applications will need to be quit and reopened for it to take effect in the application.
    – qff
    Commented Dec 28, 2021 at 13:42
-1

Pop-over menu also won't appear when the Key Repeat slider is set to Off in the Keyboard pane of System Preferences.

enter image description here

1
  • 2
    But it will also not repeat the character, which is the desired effect of the questioner Commented Jul 17, 2020 at 20:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .