I'm attempting to import an mp3 into garageband for some basic editing.

I used the media browser to locate the file and then I 'dragged and dropped' main area ('drag apple loops here!')- a quick message appears to say it's importing. However, when the message disappears there is a new track but no music.

I checked the whole track to make sure it wasn't sitting at either end and I couldn't see it but alas that shed no light as to where the 'imported' track had vanished to.

I've attached an image - although I'm not really sure how much use it's going to be.

Facts: Running Mac OS X 10.7.2, Garageband '11 v 6.0

enter image description here

  • Have you tried importing it into iTunes and then loading it from iTunes? Commented Nov 22, 2011 at 15:40
  • Yes, I discovered tat the media browser does not display the song unless it is imported into iTunes first.
    – Sheldon
    Commented Nov 22, 2011 at 15:52

3 Answers 3


Usually, we can easily import MP3 files to GarageBand (especially GarageBand 11)

However, sometimes the import process will encounter difficulty in importing an MP3 into GarageBand in two situations:

Situation 1: GarageBand only imports MP3 files which have the extension in lower case: ".mp3". If you try to import MP3 files (like MP3 recorded from the Olympus LS-10) with the extension in upper case: ".MP3", GarageBand will refuse to import those kinds of MP3 audio.

In this case, change the MP3 file extension to lower case in order to import MP3 to GarageBand.

Situation 2: GarageBand only supports those MP3 audio files which have a sample rate of 44.1 kilohertz (kHz) and a bit depth of 16 bits.

In this case, it will be necessary to convert the MP3 file(s) to GarageBand's more compatible AIFF file format.

The following link provides instructions for two methods to convert an MP3 file to a AIFF file at: How to Convert and Import MP3 to GarageBand?


It does this when your project has become too full. Try deleting tracks out of your project and then drag the audio file back into Garage Band and it should turn up blue.


I had the same problem! I tried right clicking the song in iTunes and chose "Create MP3 version". Then I went back to GarageBand and tried to import the song. Voila! It worked! Hope it works for you, too ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .