When I turn on the Mac firewall I get prompted to allow the MS office apps (Word, Excel, Powerpoint) to accept incoming connections. Why is this, and is it safe to allow it ?

I'm running Mac OS 10.7.2

  • While cruising through my System Prefs (Mac) I noticed that my Firewall was off, has been for 3 years, I guess. I set it to on and upon opening an Excel SS doc.(Office for Mac 2008)got a Microsoft message about incoming network connections; advising that denying them may limit the application's behaviour (the application I bought and paid for). Going back into System Prefs while the document is still open and the message is still displayed, and turning the Firewall protection off and then right on again gets rid of the message, and I have not so far experienced any misbehaviour by the applicat
    – user18096
    Commented Feb 1, 2012 at 23:33

4 Answers 4


I can't speak for Office 2011 because it requires you to activate your serial number with Microsoft, but in Office 2008, Office 2004 and Offive v.X, the incoming network connection is part of Microsoft's anti-piracy efforts. Since each copy of Office is activated with a unique product key, Office products open an incoming network connection and listen for connections from other instances of Microsoft Office on the network. When connections are established, the two instances of Office will trade product keys and make sure they are not the same. If they are the same, then one user is forced to close their copy of Office.

I recommend instructing your firewall NOT to allow Office to accept inbound network connections.

Here's a link to Macworld that speaks about this 'feature':


  • Adobe Photoshop/Illustrator/etc. and QuarkXPress used to do this as well.
    – Roy Tinker
    Commented Nov 22, 2011 at 17:34
  • 3
    I can't comfirm if it specifically is the anti-piracy check causing this, but I upvoted because I do believe by default you should disallow all incoming connections except the services you trust and explicitely want to be available from the outside.
    – Gerry
    Commented Nov 23, 2011 at 10:06
  • Please do not vote on a 'belief'. Use references to support your comments. Thank you.
    – Sheldon
    Commented Nov 23, 2011 at 10:50
  • 1
    @Sheldon he's right. If you don't know what it's for or why it's required, deny it. That's safe computing practices.
    – Josh
    Commented Nov 27, 2011 at 17:30

I was plagued mercilessly by this problem with all Microsoft Office 2008 applications on several fresh installs of Mavericks and Yosemite. Here is how I finally got it to go away. Hope it helps some of you:

  1. close the affected apps
  2. delete any firewall settings for that app
  3. delete all .plist files and other preferences found in /Library/Preferences, /Library/Caches, ~/Library/Preferences, and ~/Library/Caches (in my case this included all files in preferences folders named com.microsoft.*.plist and all subfolders in those folders bearing the name Microsoft). Don't worry; properly coded apps will restore their own plist files.
  4. launch each app again and choose "deny" (or "allow", according to your preference) in the dialogue about incoming connections
  5. closing the app, and opening again to verify that the firewall setting had been remembered.

Note that I also had previously forced a re-signing of the apps using ad-hoc code signing in a terminal window:

 sudo codesign --force --sign - <full path to application>

For example:

 sudo codesign --force --sign - /Applications/Microsoft\ Office\ 2008/Microsoft\ Excel.app

I am not sure whether or not the re-signing step helped the system remember the settings. You can read about code signing here:


  • But won't it remove any settings I changed?
    – Florian F
    Commented May 27, 2017 at 18:41
  • This solution didn't work for me.
    – Jason
    Commented Jan 24, 2018 at 21:52

This problem still exists more than 4 years after it was first reported. I am running Office for Mac 2011 under Mac OS 10.10.5. I get the annoying message asking me "Do you want the application “Office365Service.app” to accept incoming network connections?" Of course I have nothing to do with anything concerning Office 360. So I deny it, but it comes back up 10 or 180 minutes later, or a day later if I'm lucky.

I have called Microsoft. They claim it is because a .plist file has become corrupted. Sure enough, when I deleted one or more of these files, the problem went away ... for a month or two. Then it recurred. Now I forget where the offending file(s) was(were).

My take on this: it is a bug that Microsoft refuses to acknowledge or fix.


I would add, that a lot of the Ms-Office documentation is online. It might has something to do with that.

  • This doesn't really explain why MS-Office needs to accept incoming connections (which are triggered from outside). Accessing online documentation requires an outgoing connection.
    – nohillside
    Commented Nov 22, 2011 at 18:21
  • Could be possible, documentation is updated from the exterior. But still the anti-piracy seems to be the most plausible answer indeed.
    – Zenklys
    Commented Nov 22, 2011 at 19:26
  • And how should MS know where to push new documentation? If an update is necessary, it will be triggered by MS Office contacting a Microsoft server and querying for a new version.
    – nohillside
    Commented Nov 22, 2011 at 19:32
  • I think you are understanding it wrong. Incoming connections can mean, Microsoft send us a stream of data. Which might be an update/documentation or whatever. Incoming connections does not mean, suddenly out of nowhere a microsoft server tries to access your mac.
    – Zenklys
    Commented Nov 23, 2011 at 9:39
  • 2
    @Zenklys, no, incoming connections means the connection was initiated from outside. An update request is initiated locally (even though that might be done in the background, and so the request is not very visible), at which point Microsoft's servers might be responding with an update download. Because it's initiated locally, it is an outgoing connection.
    – Gerry
    Commented Nov 23, 2011 at 10:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .