My system is kept fully up to date and I still see this problem intermittently, although not as often as I used to; I would say that this has not been fully fixed. If there are any workarounds other than rebooting, this would be a good place to collect them. This has previously been closed and re-opened due to demand.

Cutting and copying do not always seem to change the content of the clipboard, whether triggered from a keyboard shortcut, a menu option, or even drag and drop. At the least this results in sometimes praying the wrong information, at worst it results in cut randomly acting like a delete key. The behavior as I have observed started out as staying to randomly occur and then consistently happen until the system is rebooted, for all programs including finder and the terminal.now it seems to stay randomly and then intermittently but at a high frequency occur, again regardless of program.

Searching on google produces no useful results for this issue.

Copied from Drag & drop and cut & paste not working [closed] so that others may find this question in search

Possible Duplicate:
Can anyone explain this clipboard behaviour?

This is weird. I'm on OSX Lion, and sometimes both drag & drop and cut & paste stop working, at the same time. They stop working in any program, not just the Finder. And it's not just the shortcut: if I try to right click and select "Copy" it doesn't work either.

This has happened three times so far. A reboot fixes it, but it's annoying at best. Any solution?

Does anyone know of any way to fix this, or otherwise how to report this to Apple?

@bmike I have removed other questions, I had this issue on a series of Macs, both iMacs and unibody MBPs, under OSX 10.7 and 10.8. I no longer use OSX so can't really contribute any more to this question.

  • 2
    Let's tighten this up. It continues to get "me too" answers. First up would be to edit out all the side questions. Asking if others have the problem is not good for this site. Choose whether you want to focus this on how to troubleshoot the issue or how to report a bug to Apple but not both.
    – bmike
    Commented Apr 6, 2015 at 22:44
  • Similar: Copy and paste stops working
    – kenorb
    Commented Jul 15, 2017 at 15:57

4 Answers 4


Based on this post, the following worked for me.

Check if the pboard daemon is running:

launchctl list | grep com.apple.pboard

If the pboard daemon is running, then stop and start it. If it's not running, start it:

launchctl stop com.apple.pboard
launchctl start com.apple.pboard

Then, you may need to restart the application(s) where cut-and-paste is not working.

  • This worked for me on Mountain Lion (10.8.5). I believe this answer deserves more attention. It's worth emphasizing that applications need to be restarted individually - it may be easiest to restart with the "Reopen windows..." option on.
    – duozmo
    Commented Jan 12, 2014 at 18:27
  • This fixes the same issue with both copy & paste and drag & drop not working. After running the launchctl commands you'll want to restart Finder (hold alt and right-click on Finder, then click Relaunch) as well as the apps that were copying from and pasting too. This is far less inconvenient than restarting each time. For the record, this only started occurring for me when I installed a Windows game using Crossover. Commented Jun 1, 2015 at 3:23
  • To agree with @RobinHawkes , this bug just hit me after installing wine (to which I am running steam). It is currently not running, but I cannot copy/paste in certain windows (currently, the HipChat application). Google chrome seems more than happy to copy/paste, though, so this might be an XQuartz issue?
    – OzBarry
    Commented Oct 14, 2015 at 19:30
  • The other answer about using Edit > Show Clipboard in Finder is worth mentioning; I restarted pboard, but until I restarted finder, Show Clipboard was empty. Once Show Clipboard displays the name of the file you've copied, you should be fine - i.e. it's the copy part of the process that seems to be failing. This is the very first time I've seen this and I hadn't recently installed anything (I use Launchbar and it actually warned me the clipboard wasn't working and I should probably logout and in again) Commented Jun 6, 2018 at 8:57

Apple appears to have introduced a bug into this particular point in their frameworks, I do also experience this bug often after having relaunched certain applications. The reason copy/paste and drag and drop stop working at the same time is because they are both a function of the NSPasteboard API.

If you go to the finder under Edit>Show Clipboard, and the contents is none even after having copied something then the component of the OS responsible for handeling pasteboard events has crashed. This is beyond your control, a work arround may exist by manually reloading the required component using launched, however the simplest solution is to save what you're doing reboot.

  • This seems to have the most information on the problem to date - if anyone has any information on how to restart the responsible service, that would be appreciated :) Commented Dec 21, 2012 at 12:05
  • 7
    As written in the other answer, there is the service com.apple.pboard. Restarting this alone did not resolve the problem for me. However, a combination of the following did work (not sure what it needs): killall pbs (restart service com.apple.pbs), killall pboard, restart the application which want to use the clipboard (at least this is mandatory)
    – Albert
    Commented Jan 20, 2015 at 12:52
  • Get this man a beer!
    – gprasant
    Commented Jun 22, 2015 at 16:16

Al, several things.

  1. what version of Lion are you using:

Apple Menu > About this mac.

  1. Have you checked for software updates?

System Preferences > Software Update.

  1. Have you repaired permissions?

Finder > Applications > Utilities > Disk Utility.

(These are basic troubleshooting steps for any mac issue by the way).

Then, when you think something hasn't been captured by the copy command, could you open TextEdit (Applications > TextEdit), and paste to there...

Finally, if something is funky, it often helps to create a test user account (System Preferences > Users and Groups), and see if the behavior repeats there. Let us know. Hope this helps get you started with things..

Oh one more thought, without reading everything again, I presume you've tried this with both the keyboard and the mouse.. Could it be that one of them is a bit sketchy? For example, open up TextEdit, and try typing the c key over and over, and then the p key..

  • Lion 10.7.2, AFAIK everything is up to date, I'll have a check on permissions but I was trying to copy and paste text between different/the same text documents. It's not the keyboard either - mousing displays the same intermittent bug Commented Dec 5, 2011 at 13:04
  • I'm seeing this exact behavior with 10.7.4 still.
    – Ken
    Commented Jun 11, 2012 at 14:39
  • 1
    If rebooting fixes the problem, then either it's not touching disk (likely), or OS X repairs permissions on reboot (unlikely), and in either case I'm not sure how "repairing permissions" on its own would be relevant.
    – Ken
    Commented Jun 11, 2012 at 14:42
  1. Sometimes you're not allowed to copy and paste from certain places (websites, Java, Flash content, etc.)
  2. It is flashing because you're holding the Cmd+C down too long. Press it once.

If this is still a problem, you should try a third party application for a clipboard utility from a site like MacUpdate.

  • 1
    "It is flashing because you're holding the Cmd+C down too long." Huh? No, keyboard shortcuts always highlight their parent menu item. Unless the OP meant "flashing repeatedly", but I didn't get it that way. Plus, most third party apps interact with OS X's base clipboard to add history to it, so if something's broken there, it won't change anything.
    – MattiSG
    Commented Nov 21, 2011 at 18:17
  • I do only press it briefly - what I meant is that when I am looking at the top of the screen when I do it, I see the menu item appear selected for the short duration while the keys are both depressed. I have installed Jumpcut now as it at least lets me know if I have copied what I expected to. Commented Nov 22, 2011 at 10:29

Not the answer you're looking for? Browse other questions tagged .