This question already has an answer here:

Suddenly the keyboard and trackpad of my macbook pro 13' 2015 model stopped working, this issue happened when I upgrade from sierra to high sierra. Also I already tried re-installing the OS from the internet recovery way, still the issue is present. Then I tried booting my macbook pro on Remix OS (android) both the keyboard and trackpad is working fine.

enter image description here enter image description here enter image description here

marked as duplicate by fsb, nohillside Mar 16 '18 at 7:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you boot into Safe Mode (hold shift while booting)? – Allan Mar 16 '18 at 3:55
  • This looks like a hardware problem amplified by a software change in driver timeouts. None of the advised resets will be of any help. Please read this excellent answer: apple.stackexchange.com/a/246403/22003 – dan Mar 16 '18 at 10:01
  • Your excellent test with another OS proves there is a software component of the problem. Test with an external USB keyboard to check for a hardware component of the problem. Beware: some software changes may exhibit poor quality hardware behaviour. – dan Mar 16 '18 at 10:08
  • @danielAzuelos I tried using wired and bluetooth keyboard and mouse, they are working fine – flotTopz Mar 17 '18 at 3:35
  • @Allan yah tried Safe Mode but still it's not working also – flotTopz Mar 17 '18 at 3:36

I recommend resetting the SMC and the NVRAM (PRAM) 1st and see if they help get the keyboard and/or the trackpad working again.

Since they work on Remix OS it could also be a software issue, after you reset the SMC and NVRAM if neither starts working then try safe mode. If it doesnt work in safe mode (safe boot) then try with another user account. If the same results then you'll need to backup your Mac and then reinstall MacOS.

If it still persists afterwards than it may be a connection error, you'll need to take it to the Apple Store.

But do everything else 1st.

  • 1
    Already tried the SMC, NVRAM and safe mode...still having the problem. I think i'll try reinstall macOS – flotTopz Mar 17 '18 at 4:27
  • Ok, keep me posted. did you try with a new user yet? – Melvin Jefferson Mar 17 '18 at 21:43
  • tried also the other user still the same, Also tried to load El Capitan on a external USB, also still not working, I think I will just bring this on Apple store – flotTopz Mar 24 '18 at 10:49

Not the answer you're looking for? Browse other questions tagged .