0

I have a 15" MacBook Pro 2016 and I can't figure out how can I remove the saved auto-fill emails like I can on Windows/Linux using the keyboard:

  1. Select one of the suggested emails from the drop down via arrows
  2. Press ShiftDelete
  3. And viola the email is removed/forgotten

I've found this link on Google Support which suggests that I use ShiftFnDelete on my Mac and it should do the same, but for one laptops keyboard does not have the Delete key, and even though I have the delete_forward key remapped over Caps Lockit does nothing.

Is there any other way I can do this, I'm only interested in solutions via the keyboard, not the other solutions using Chrome's settings etc...

Pick of the auto fill drop down:

autofill example

  • Two things....1) It's delete backward or Backspace. 2) Are you expecting a "hidden, undocumented" keystroke to do what you want in lieu of a broken keyboard and a resistance to using the settings in Chrome? – Allan Mar 15 '18 at 16:51
  • 1) I've remapped the Capslock to delete_or_backspace and still it does not remove them from the list... 2) I'm not sure what you've said – Mihailo Mar 15 '18 at 16:54
  • You have a broken delete key and remapping doesn't work and you're unwilling to use settings...the only thing I can suggest is to fix the keyboard or use an external one. – Allan Mar 15 '18 at 17:00
  • The keyboard is not broke, it is just designed without that button. Yeah remapping doesnt seem to work... I know how to do it via settings, but itsa chore, so I wanted to learn to do it the faster way. Ty for responding. – Mihailo Mar 15 '18 at 18:25
  • The Delete key mentioned by Google is the “backspace” key ... which on my Mac keyboard is very clearly labeled Delete. Fn+Delete (backwards) is the equivalent of the (forward) Delete key on a full sized Windows keyboard. – samh Aug 16 '18 at 10:30
1

If you are loging in with your google account in Chrome browser: It can be done by signed out your google account after clear all the autofill setting in Chrome setting and un-sync auto-fill setting. Then you will not get any auto fill drop down even though you sign in with your google account again.

|improve this answer|||||
  • This won't help enable me to use the Shift + Delete shortcut – Mihailo Aug 16 '18 at 9:23
0

You have the correct answer. Here is a question on Superuser.SE that lists the keyboard shortcuts for multiple keyboards, include Mac laptops.

https://superuser.com/questions/175250/how-to-remove-one-or-all-auto-complete-text-entries-in-chrome

|improve this answer|||||
  • Thank you for showing this question to me, but non of the suggested methods worked, and the comments themselves state that it does not work on new MacBook Pros... I guess I'll have to go the settings way – Mihailo Mar 16 '18 at 11:27
  • I use the fn+shift+delete on my MacBook Pro and it works just fine. Not sure why yours wouldn't be functioning the same. – Unassuming Guy Mar 16 '18 at 14:34
  • Which MacBookPro do you have? The one I have (2016 15'') has the keyboard layout without the delete key. – Mihailo Mar 16 '18 at 14:38
  • MacBook Pro 2017 with touch bar. The key in the top right corner says Delete even though it acts as the backspace. – Unassuming Guy Mar 16 '18 at 14:43
  • Yeah I've tried doing fn+shift+backspace(delete) but to no avail... :[ – Mihailo Mar 16 '18 at 14:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .