2

I commonly use the cmd-space shortcut to bring up the spotlight, but as of yesterday it no longer works. I did not knowingly update my software beforehand, I do not have any conflicts in the keyboard shortcuts (no yellow triangle), and I only have one input source.

I have done a pretty thorough search for solutions; here are some pages I have read: (1) (2) (3) (4) (5) (6). Below are the common solutions that have not worked for me:

  • Restarted the machine. No change.
  • Restored the defaults on all keyboard shortcuts. No Change.
  • Changed the desktop resolution. No change.
  • Changed the shortcut. Spotlight works with essentially any other shortcut, but I am used to cmd-space.
  • Reset the spotlight index (sudo mdutil -E / or killall Dock). This temporarily enables the shortcut but the problem surfaces after either closing the laptop's lid or changing the application window.
  • Remove the HIToolbox.plist and restart (rm ~/Library/Preferences/com.apple.HIToolbox.plist). This enables the shortcut for a couple seconds immediately after startup but then the problem resumes.
  • Closing applications with potentially conflicting shortcuts. I can't say with 100% certainty that I have covered everything but I have combed through my app shortcuts and closed out of anything that might be the problem. To reiterate, this was working fine until yesterday.
  • First aid on the disk. No change. I assume this would fix permissions issues if there were any.

One last piece of odd behavior: I can change the shortcut from cmd+space to cmd+option+space (and everything works), but I cannot change it back to cmd+space without hitting "restore defaults". The shortcut window remains empty until I close it or hit another shortcut.

At my wits end here! Has anyone solved this before?

5

I found out that BetterTouchTool was running in the background and somehow had cmd-space assigned as a shortcut with no action (I definitely do not remember doing this). For others with this issue, I would advise carefully considering apps running in the background when checking for conflicts.

4

Have you checked the system preferences -> Keyboards -> Shortcuts -> Spotlight and made sure it was checked?

Does it work in safemode? What about other user accounts?

If not then you may need to reinstall MacOS from recovery mode.

  • 1
    I did ensure it was checked! In the end there was a shortcut conflict with an app running in the background. – Nolan Conaway Mar 14 '18 at 13:06
  • 1
    mine was unchecked, not sure why but thanks for suggesting this! – Orlando Oct 8 '18 at 16:48
1

I have been in the mac field for several years now and have found the following command has not let me down so far.

Information
This involves disabling the System Integrity Protection briefly for the purpose of writing to an otherwise "locked" (during normal boot) directory. Disabling the System Integrity Protection is not recommended for long periods of time as it is possible to "damage" files that macOS typically prevents you from changing. However, this is the only solution I have found to work reliably.

Steps

  1. Boot into Recovery mode on your mac by restarting, holding CMD + R upon restart.
  2. From the menu bar of Recovery mode, choose Utilities, then Terminal.
  3. Type: csrutil disable to disable System Integrity Protection. You can use csrutil status to check its current state.
  4. Reboot the mac as advised (into normal mode, not recovery).
  5. Open Terminal (found in the Utilities folder under Applications)
  6. Type: sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist (all in one line), hit Return/Enter key.
  7. Relaunch the Mac
  8. Give Spotlight a try using the key combination(s).
  9. Repeat steps 1, 2, 3, 4; changing the command in step 3 to csrutil enable to re-enable the System Integrity Protection. Again, you may use csrutil status to check its current state.

What this does is actually does is re-initiate Spotlight's launch daemon (using the launchctl command). Anyway, what's important is that it works, although I am not sure what effect the key combination change had on the way it functions - this may have to be set back to its defaults.

Give it a go and report back on how you make out. I'd be happy to follow up with you on this.

  • 1
    Hey, thanks for the detailed response! I am glad you posted this for others; but, as i answered above, in my case it was as simple as a background task hogging that shortcut without my knowledge. Still don't know how the shortcut was enabled, as i did not recently install/update and i certainly did not intentionally overwrite the shortcut. – Nolan Conaway Mar 13 '18 at 22:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .