3

I have a 13" MacBook Pro (Mid 2012) that is failing to fully boot.

What happens once I press the power button:

  • Screen turns on, and the typical boot-up loading screen with the Apple logo appears
  • Once the loading progress bar reaches about halfway, the screen goes black
  • About 10 seconds later, the login screen appears
  • I click on my account, type my password, and press enter

Now this is when the funky stuff begins....

  • The computer does not transition from showing the password box to the loading bar
  • Sections of the screen are now gray & green and slightly jittery

After roughly 2 minutes of spazzing out with along with the odd colors showing up....

  • Screen goes black
  • Fan is still fanning
  • Repeated beeping noise

Annnddd thats when I hold the power button and come to you fellas for some help

I'm looking to diagnose the problem in order to hopefully fix it, any help/recommendation/advice would be much appreciated.

Thanks


The work-around:

Thinking the graphics card might be the problem, I did the following:

  • Uninstalled macOS
  • Installed Debian without GUI (command-line only)

At the end:

  • Laptop does not freeze anymore
  • Laptop does not beep anymore
  • No more black/green/gray pixels
  • 1
    Can you boot up to an external drive or boot into recovery mode at all? – Maximus Mar 12 '18 at 21:28
  • 1
    It sounds like your drive is crashing. See apple.stackexchange.com/a/238924/119271 and apple.stackexchange.com/a/231920/119271 – Allan Mar 12 '18 at 21:41
  • 1
    Any action requiring a GUI leads to a crash. I am attempting to install a base Debian OS (command-line only), in order to test the graphics card theory. I will look into the hard drive crash possibility if the issue is not resolved. Thanks everyone – slightly_toasted Mar 12 '18 at 21:53
  • 1
    If you want to test the graphics theory, start macOS in single user mode – John Keates Mar 13 '18 at 2:05
2

You can run Apple's built it hardware test, Turn on your Mac, then immediately press and hold the D key on your keyboard. Keep holding the D key until you see the Apple Hardware Test

I feel it could be a graphics card issue because it seems to play up when you get to the login screen where the computer actually requires the use of the graphics card.

  • Unfortunately I ran across the same problem, except this time the jittery blocks were black, when I held D on boot. No beeping this time (likely not RAM issue). Graphics card must be it, gonna test it with a command-line only Linux install. Thanks! Will resolve this post if it fixes the problem – slightly_toasted Mar 12 '18 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .